aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-04-05 12:36:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-04-05 12:36:23 +0000
commita4fbc42a5ab00346505d5e3cde41141da85232d1 (patch)
treec0d1bb56aebfc49715e3763b24a9f1a736963411 /toolchain/gcc
parentd32ac499b87e188755b5e3245e1d0bc181e6e6ed (diff)
downloadupstream-a4fbc42a5ab00346505d5e3cde41141da85232d1.tar.gz
upstream-a4fbc42a5ab00346505d5e3cde41141da85232d1.tar.bz2
upstream-a4fbc42a5ab00346505d5e3cde41141da85232d1.zip
toolchain: allow choosing the MIPS64 user-land ABI
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36205 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 8305aa9fc1..c6b961735c 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -113,7 +113,8 @@ GCC_CONFIGURE:= \
--with-host-libstdcxx=-lstdc++ \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
- $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
+ $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
+ --with-abi=$(subst ",,$(CONFIG_MIPS64_ABI))) \
--with-gmp=$(TOPDIR)/staging_dir/host \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--disable-decimal-float