aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-19 23:12:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-19 23:12:00 +0000
commit0dd9afae4e81e557ff30d1b41e177631f624bfaa (patch)
treec33f41aa0e134efb589686c1bbd4e6029ddb2559 /toolchain/gcc
parentb316ab42bb1a34769d410b41aa62ffcc1b11f9e3 (diff)
downloadupstream-0dd9afae4e81e557ff30d1b41e177631f624bfaa.tar.gz
upstream-0dd9afae4e81e557ff30d1b41e177631f624bfaa.tar.bz2
upstream-0dd9afae4e81e557ff30d1b41e177631f624bfaa.zip
[toolchain] gcc: build with HOST_CFLAGS
Turns on -O2 optimization when building GCC thus making the cross-compiler a little faster (about 25%). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34266 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 6e4c61214b..924ed90a63 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -180,6 +180,7 @@ endif
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) \
+ CFLAGS="$(HOST_CFLAGS)" \
CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"