aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
commitf0f9ec9c5626a4124234638a0ed2f4c99c435ff8 (patch)
treeeaa59400aae15a69c47faa369e3bf53690f18592 /toolchain/gcc
parentba5b41f0dcd3b89ab6ff031147d99ec6d4a132ef (diff)
downloadupstream-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.tar.gz
upstream-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.tar.bz2
upstream-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.zip
add a modified version of the mips64 patch from #4603
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15249 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 6f2b626f38..d7170ea8ec 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -73,6 +73,7 @@ GCC_CONFIGURE:= \
--disable-nls \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
+ $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
ifneq ($(CONFIG_GCC_VERSION_4_3),)
GCC_BUILD_TARGET_LIBGCC:=y
@@ -189,6 +190,7 @@ define Stage2/Configure
ln -sf ../include $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/sys-include
rm -rf $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib
ln -sf ../lib $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib
+ $(if $(CONFIG_mips64)$(CONFIG_mips64el),ln -sf ../lib64 $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib64)
(cd $(HOST_BUILD_DIR2); rm -f config.cache; \
$(GCC_CONFIGURE_STAGE2) \
);