aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-10-03 12:54:07 +0000
committerMichael Büsch <mb@bu3sch.de>2010-10-03 12:54:07 +0000
commitef39b40498680c5f29fffbeb88fef3e96b1d33b6 (patch)
tree940cf0a57c57d5fee01760097f72c7790584ef3e /toolchain/gcc
parentf47c187bda4e5cc3ba492800fb4cc2073f8230a2 (diff)
downloadupstream-ef39b40498680c5f29fffbeb88fef3e96b1d33b6.tar.gz
upstream-ef39b40498680c5f29fffbeb88fef3e96b1d33b6.tar.bz2
upstream-ef39b40498680c5f29fffbeb88fef3e96b1d33b6.zip
optionally support parallel toolchain build. This defaults to off, because certain toolchain versions are known to break on parallel build. However, it significantly speeds up the build and latest versions of the tools do compile fine.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23196 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index e2277207b8..8c293dd332 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -173,7 +173,7 @@ endif
GCC_MAKE:= \
export SHELL="$(BASH)"; \
- $(MAKE) \
+ $(MAKE) $(TOOLCHAIN_JOBS) \
CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"