aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/llvm/300-libstdc++-pic.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-04-01 15:08:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-04-01 15:08:38 +0000
commit9231162c7e69836e06d9810d0f75f706f72789ca (patch)
tree6976636d7de73c321a5c6cb7470ae4dd76993d91 /toolchain/gcc/patches/llvm/300-libstdc++-pic.patch
parent71e9171717de01c77165e4384f91b25155443446 (diff)
downloadupstream-9231162c7e69836e06d9810d0f75f706f72789ca.tar.gz
upstream-9231162c7e69836e06d9810d0f75f706f72789ca.tar.bz2
upstream-9231162c7e69836e06d9810d0f75f706f72789ca.zip
llvm is marked broken for two and a half year now, nuke it
SVN-Revision: 36145
Diffstat (limited to 'toolchain/gcc/patches/llvm/300-libstdc++-pic.patch')
-rw-r--r--toolchain/gcc/patches/llvm/300-libstdc++-pic.patch50
1 files changed, 0 insertions, 50 deletions
diff --git a/toolchain/gcc/patches/llvm/300-libstdc++-pic.patch b/toolchain/gcc/patches/llvm/300-libstdc++-pic.patch
deleted file mode 100644
index 165dc3708d..0000000000
--- a/toolchain/gcc/patches/llvm/300-libstdc++-pic.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-# DP: Build and install libstdc++_pic.a library.
-
---- a/libstdc++-v3/src/Makefile.am
-+++ b/libstdc++-v3/src/Makefile.am
-@@ -257,6 +257,12 @@ CXXLINK = $(LIBTOOL) --tag CXX --mode=li
- $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
-
-
-+install-exec-local:
-+ifeq ($(enable_shared),yes)
-+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
-+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
-+endif
-+
- # Added bits to build debug library.
- if GLIBCXX_BUILD_DEBUG
- all-local: build_debug
---- a/libstdc++-v3/src/Makefile.in
-+++ b/libstdc++-v3/src/Makefile.in
-@@ -657,7 +657,7 @@ info-am:
-
- install-data-am: install-data-local
-
--install-exec-am: install-toolexeclibLTLIBRARIES
-+install-exec-am: install-toolexeclibLTLIBRARIES install-exec-local
-
- install-info: install-info-am
-
-@@ -690,6 +690,7 @@ uninstall-am: uninstall-info-am uninstal
- distclean-libtool distclean-tags distdir dvi dvi-am html \
- html-am info info-am install install-am install-data \
- install-data-am install-data-local install-exec \
-+ install-exec-local \
- install-exec-am install-info install-info-am install-man \
- install-strip install-toolexeclibLTLIBRARIES installcheck \
- installcheck-am installdirs maintainer-clean \
-@@ -799,6 +800,13 @@ build_debug: stamp-debug
- install_debug:
- (cd ${debugdir} && $(MAKE) \
- toolexeclibdir=$(glibcxx_toolexeclibdir)/debug install)
-+
-+install-exec-local:
-+ifeq ($(enable_shared),yes)
-+ $(AR) cru libstdc++_pic.a *.o $(top_builddir)/libsupc++/*.o
-+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
-+endif
-+
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT: