aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/arc-2017.09-release/940-no-clobber-stamp-bits.patch
diff options
context:
space:
mode:
authorEvgeniy Didin <Evgeniy.Didin@synopsys.com>2018-01-24 20:26:03 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-27 16:46:44 +0100
commite47fe3284f25c0d7354f239ea8424b96dfe5b36d (patch)
tree3d7664b58bf65eee13543aee8fa0848036cd25c9 /toolchain/gcc/patches/arc-2017.09-release/940-no-clobber-stamp-bits.patch
parent53021ce7f24b0fd80a6f50517a25d762d783102b (diff)
downloadupstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.tar.gz
upstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.tar.bz2
upstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.zip
toolchain/arc: update to the most recent release arc-2017.09
This commit finally bumps ARC tools to the most recent arc-2017.09 release version. ARC GNU tools of version arc-2017.09 bring some quite significant changes like: * Binutils v2.29 with additional ARC patches * GCC 7.1.1 with additional ARC patches More information on this release could be found here: https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/tag/arc-2017.09-release Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com> CC: Alexey Brodkin <abrodkin@synopsys.com> CC: John Crispin <john@phrozen.org>
Diffstat (limited to 'toolchain/gcc/patches/arc-2017.09-release/940-no-clobber-stamp-bits.patch')
-rw-r--r--toolchain/gcc/patches/arc-2017.09-release/940-no-clobber-stamp-bits.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/arc-2017.09-release/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/arc-2017.09-release/940-no-clobber-stamp-bits.patch
new file mode 100644
index 0000000000..8b88b4066d
--- /dev/null
+++ b/toolchain/gcc/patches/arc-2017.09-release/940-no-clobber-stamp-bits.patch
@@ -0,0 +1,33 @@
+commit 548d9a008ff265e9eaa3c7e0e6e301c6bd5645e6
+Author: Felix Fietkau <nbd@openwrt.org>
+Date: Fri Dec 12 17:01:57 2014 +0000
+
+ gcc: don't clobber stamp-bits with a symlink to itself
+
+ Several versions of gcc have an issue in libstdc++v3 where the build may
+ clobber stamp-bits with a link to itself. This doesn't manifest itself
+ on all systems. On several Ubuntu systems, this doesn't appear to be a
+ problem, but it is an issue on Fedora 16 systems.
+
+ To fix the issue, we'll simply filter out stamp-bits from the symlinks
+ to be generated.
+
+ Note: gcc 4.4.7 is unaffected by this issue, so no fix is necessary
+ there.
+
+ Signed-off-by: John Szakmeister <john@szakmeister.net>
+
+ SVN-Revision: 43669
+
+
+--- a/libstdc++-v3/include/Makefile.in
++++ b/libstdc++-v3/include/Makefile.in
+@@ -1476,7 +1476,7 @@ stamp-bits: ${bits_headers}
+ @$(STAMP) stamp-bits
+
+ stamp-bits-sup: stamp-bits ${bits_sup_headers}
+- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
++ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
+ @$(STAMP) stamp-bits-sup
+
+ stamp-c_base: ${c_base_headers}