aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2017-08-22 11:01:07 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-16 19:33:37 +0200
commit3f4f580954fd90ce3ad6eb6ca6ab7b96eb66539c (patch)
tree849a11e62055caa16a59688633684b6f861859b4 /toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch
parent820101873d6ac197cf5aff327f784ec3584fe1c7 (diff)
downloadupstream-3f4f580954fd90ce3ad6eb6ca6ab7b96eb66539c.tar.gz
upstream-3f4f580954fd90ce3ad6eb6ca6ab7b96eb66539c.tar.bz2
upstream-3f4f580954fd90ce3ad6eb6ca6ab7b96eb66539c.zip
toolchain: gcc: update 7.x to 7.2.0
Bump gcc from 7.1 to 7.2 Compile & run tested: ar71xx Trace history of current patches and update with commit ref & comment to give more clue as to why they're still around/needed. Some have changed form since the original commit but some clue is better than no clue at all. Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk> Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch')
-rw-r--r--toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch
new file mode 100644
index 0000000000..8b88b4066d
--- /dev/null
+++ b/toolchain/gcc/patches/7.2.0/940-no-clobber-stamp-bits.patch
@@ -0,0 +1,33 @@
+commit 548d9a008ff265e9eaa3c7e0e6e301c6bd5645e6
+Author: Felix Fietkau <nbd@openwrt.org>
+Date: Fri Dec 12 17:01:57 2014 +0000
+
+ gcc: don't clobber stamp-bits with a symlink to itself
+
+ Several versions of gcc have an issue in libstdc++v3 where the build may
+ clobber stamp-bits with a link to itself. This doesn't manifest itself
+ on all systems. On several Ubuntu systems, this doesn't appear to be a
+ problem, but it is an issue on Fedora 16 systems.
+
+ To fix the issue, we'll simply filter out stamp-bits from the symlinks
+ to be generated.
+
+ Note: gcc 4.4.7 is unaffected by this issue, so no fix is necessary
+ there.
+
+ Signed-off-by: John Szakmeister <john@szakmeister.net>
+
+ SVN-Revision: 43669
+
+
+--- a/libstdc++-v3/include/Makefile.in
++++ b/libstdc++-v3/include/Makefile.in
+@@ -1476,7 +1476,7 @@ stamp-bits: ${bits_headers}
+ @$(STAMP) stamp-bits
+
+ stamp-bits-sup: stamp-bits ${bits_sup_headers}
+- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
++ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
+ @$(STAMP) stamp-bits-sup
+
+ stamp-c_base: ${c_base_headers}