aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/7.1.0/940-no-clobber-stamp-bits.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-04 15:18:13 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-25 19:01:07 +0200
commit70c2c8ff3938d75425d544aac6a7e9966ae6a165 (patch)
tree2b277c86d79e1185990226a6b7d53978430069ab /toolchain/gcc/patches/7.1.0/940-no-clobber-stamp-bits.patch
parenta0f4b4b3a2cd4db1a2b9bab3c06970361192368f (diff)
downloadupstream-70c2c8ff3938d75425d544aac6a7e9966ae6a165.tar.gz
upstream-70c2c8ff3938d75425d544aac6a7e9966ae6a165.tar.bz2
upstream-70c2c8ff3938d75425d544aac6a7e9966ae6a165.zip
toolchain: add gcc 7.1.0 support
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gcc/patches/7.1.0/940-no-clobber-stamp-bits.patch')
-rw-r--r--toolchain/gcc/patches/7.1.0/940-no-clobber-stamp-bits.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/7.1.0/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/7.1.0/940-no-clobber-stamp-bits.patch
new file mode 100644
index 0000000000..9e5e59970e
--- /dev/null
+++ b/toolchain/gcc/patches/7.1.0/940-no-clobber-stamp-bits.patch
@@ -0,0 +1,11 @@
+--- a/libstdc++-v3/include/Makefile.in
++++ b/libstdc++-v3/include/Makefile.in
+@@ -1475,7 +1475,7 @@ stamp-bits: ${bits_headers}
+ @$(STAMP) stamp-bits
+
+ stamp-bits-sup: stamp-bits ${bits_sup_headers}
+- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
++ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
+ @$(STAMP) stamp-bits-sup
+
+ stamp-c_base: ${c_base_headers}