aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/6.3.0/820-libgcc_pic.patch
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2016-12-24 17:09:35 +0800
committerFelix Fietkau <nbd@nbd.name>2016-12-24 12:02:10 +0100
commit0a5ccfbadda79f4626202b78326c4d3ffccf9bd1 (patch)
treef16bcec33c3418bca8c26ee6b75dadcaf3fce2a2 /toolchain/gcc/patches/6.3.0/820-libgcc_pic.patch
parent16725e2db0a4fbf72e05443049df3f0cfa2ad86b (diff)
downloadupstream-0a5ccfbadda79f4626202b78326c4d3ffccf9bd1.tar.gz
upstream-0a5ccfbadda79f4626202b78326c4d3ffccf9bd1.tar.bz2
upstream-0a5ccfbadda79f4626202b78326c4d3ffccf9bd1.zip
toolchain/gcc: update 6.x to 6.3.0
This is a bugfix release Build and run tested on mvebu/Linksys WRT1900AC v1 Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Diffstat (limited to 'toolchain/gcc/patches/6.3.0/820-libgcc_pic.patch')
-rw-r--r--toolchain/gcc/patches/6.3.0/820-libgcc_pic.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/6.3.0/820-libgcc_pic.patch b/toolchain/gcc/patches/6.3.0/820-libgcc_pic.patch
new file mode 100644
index 0000000000..f925d96f66
--- /dev/null
+++ b/toolchain/gcc/patches/6.3.0/820-libgcc_pic.patch
@@ -0,0 +1,36 @@
+--- a/libgcc/Makefile.in
++++ b/libgcc/Makefile.in
+@@ -888,11 +888,12 @@ $(libgcov-driver-objects): %$(objext): $
+
+ # Static libraries.
+ libgcc.a: $(libgcc-objects)
++libgcc_pic.a: $(libgcc-s-objects)
+ libgcov.a: $(libgcov-objects)
+ libunwind.a: $(libunwind-objects)
+ libgcc_eh.a: $(libgcc-eh-objects)
+
+-libgcc.a libgcov.a libunwind.a libgcc_eh.a:
++libgcc.a libgcov.a libunwind.a libgcc_eh.a libgcc_pic.a:
+ -rm -f $@
+
+ objects="$(objects)"; \
+@@ -913,7 +914,7 @@ all: libunwind.a
+ endif
+
+ ifeq ($(enable_shared),yes)
+-all: libgcc_eh.a libgcc_s$(SHLIB_EXT)
++all: libgcc_eh.a libgcc_pic.a libgcc_s$(SHLIB_EXT)
+ ifneq ($(LIBUNWIND),)
+ all: libunwind$(SHLIB_EXT)
+ libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_EXT)
+@@ -1115,6 +1116,10 @@ install-shared:
+ chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
+ $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a
+
++ $(INSTALL_DATA) libgcc_pic.a $(mapfile) $(DESTDIR)$(inst_libdir)/
++ chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_pic.a
++ $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_pic.a
++
+ $(subst @multilib_dir@,$(MULTIDIR),$(subst \
+ @shlib_base_name@,libgcc_s,$(subst \
+ @shlib_slibdir_qual@,$(MULTIOSSUBDIR),$(SHLIB_INSTALL))))