aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/4.7.0/820-libgcc_pic.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-21 20:27:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-21 20:27:15 +0000
commitbca3953ee5f178303ed835f66784a4cb21f7c8cd (patch)
tree7bf8a5d04ed627dfbaf6ebc8aef999ea8f63a442 /toolchain/gcc/patches/4.7.0/820-libgcc_pic.patch
parentf1498531c78466ab07c1c2b1cc788f2689e9b18e (diff)
downloadupstream-bca3953ee5f178303ed835f66784a4cb21f7c8cd.tar.gz
upstream-bca3953ee5f178303ed835f66784a4cb21f7c8cd.tar.bz2
upstream-bca3953ee5f178303ed835f66784a4cb21f7c8cd.zip
gcc: remove support for 4.7.0
There are no good reasons for keeping this version around when 4.7.2 and 4.7-linaro are there. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 34296
Diffstat (limited to 'toolchain/gcc/patches/4.7.0/820-libgcc_pic.patch')
-rw-r--r--toolchain/gcc/patches/4.7.0/820-libgcc_pic.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/toolchain/gcc/patches/4.7.0/820-libgcc_pic.patch b/toolchain/gcc/patches/4.7.0/820-libgcc_pic.patch
deleted file mode 100644
index 187e6bf11d..0000000000
--- a/toolchain/gcc/patches/4.7.0/820-libgcc_pic.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/libgcc/Makefile.in
-+++ b/libgcc/Makefile.in
-@@ -862,11 +862,12 @@ $(libgcov-objects): %$(objext): $(srcdir
-
- # Static libraries.
- libgcc.a: $(libgcc-objects)
-+libgcc_pic.a: $(libgcc-s-objects)
- libgcov.a: $(libgcov-objects)
- libunwind.a: $(libunwind-objects)
- libgcc_eh.a: $(libgcc-eh-objects)
-
--libgcc.a libgcov.a libunwind.a libgcc_eh.a:
-+libgcc.a libgcov.a libunwind.a libgcc_eh.a libgcc_pic.a:
- -rm -f $@
-
- objects="$(objects)"; \
-@@ -888,7 +889,7 @@ libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_E
- endif
-
- ifeq ($(enable_shared),yes)
--all: libgcc_eh.a libgcc_s$(SHLIB_EXT)
-+all: libgcc_eh.a libgcc_pic.a libgcc_s$(SHLIB_EXT)
- ifneq ($(LIBUNWIND),)
- all: libunwind$(SHLIB_EXT)
- endif
-@@ -1043,6 +1044,10 @@ install-shared:
- chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
- $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a
-
-+ $(INSTALL_DATA) libgcc_pic.a $(mapfile) $(DESTDIR)$(inst_libdir)/
-+ chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_pic.a
-+ $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_pic.a
-+
- $(subst @multilib_dir@,$(MULTIDIR),$(subst \
- @shlib_base_name@,libgcc_s,$(subst \
- @shlib_slibdir_qual@,$(MULTIOSSUBDIR),$(SHLIB_INSTALL))))