aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/4.2.3/300-libstdc++-pic.patch
diff options
context:
space:
mode:
authorMatteo Croce <matteo@openwrt.org>2008-05-21 11:51:22 +0000
committerMatteo Croce <matteo@openwrt.org>2008-05-21 11:51:22 +0000
commitd09a02e0ed3c7200bcb322d6cb76e061439f4689 (patch)
tree9b97e59bc366e0bdda22a60f680a86d4d1f9d2a8 /toolchain/gcc/patches/4.2.3/300-libstdc++-pic.patch
parenta824434922bba71f64e5b93286afc1de1b542fc7 (diff)
downloadupstream-d09a02e0ed3c7200bcb322d6cb76e061439f4689.tar.gz
upstream-d09a02e0ed3c7200bcb322d6cb76e061439f4689.tar.bz2
upstream-d09a02e0ed3c7200bcb322d6cb76e061439f4689.zip
refresh gcc-4.2.3 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11232 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/patches/4.2.3/300-libstdc++-pic.patch')
-rw-r--r--toolchain/gcc/patches/4.2.3/300-libstdc++-pic.patch22
1 files changed, 13 insertions, 9 deletions
diff --git a/toolchain/gcc/patches/4.2.3/300-libstdc++-pic.patch b/toolchain/gcc/patches/4.2.3/300-libstdc++-pic.patch
index 560bcb237b..f396fbba61 100644
--- a/toolchain/gcc/patches/4.2.3/300-libstdc++-pic.patch
+++ b/toolchain/gcc/patches/4.2.3/300-libstdc++-pic.patch
@@ -1,9 +1,11 @@
# DP: Build and install libstdc++_pic.a library.
---- gcc/libstdc++-v3/src/Makefile.am
-+++ gcc/libstdc++-v3/src/Makefile.am
-@@ -214,6 +214,12 @@
- $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LDFLAGS) -o $@
+Index: gcc-4.2.3/libstdc++-v3/src/Makefile.am
+===================================================================
+--- gcc-4.2.3.orig/libstdc++-v3/src/Makefile.am 2006-07-28 06:57:34.000000000 +0200
++++ gcc-4.2.3/libstdc++-v3/src/Makefile.am 2008-05-21 13:45:47.465287535 +0200
+@@ -257,6 +257,12 @@
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+install-exec-local:
@@ -15,9 +17,11 @@
# Added bits to build debug library.
if GLIBCXX_BUILD_DEBUG
all-local: build_debug
---- gcc/libstdc++-v3/src/Makefile.in
-+++ gcc/libstdc++-v3/src/Makefile.in
-@@ -627,7 +627,7 @@
+Index: gcc-4.2.3/libstdc++-v3/src/Makefile.in
+===================================================================
+--- gcc-4.2.3.orig/libstdc++-v3/src/Makefile.in 2006-10-16 21:08:22.000000000 +0200
++++ gcc-4.2.3/libstdc++-v3/src/Makefile.in 2008-05-21 13:45:47.465287535 +0200
+@@ -657,7 +657,7 @@
install-data-am: install-data-local
@@ -26,7 +30,7 @@
install-info: install-info-am
-@@ -660,6 +660,7 @@
+@@ -690,6 +690,7 @@
distclean-libtool distclean-tags distdir dvi dvi-am html \
html-am info info-am install install-am install-data \
install-data-am install-data-local install-exec \
@@ -34,7 +38,7 @@
install-exec-am install-info install-info-am install-man \
install-strip install-toolexeclibLTLIBRARIES installcheck \
installcheck-am installdirs maintainer-clean \
-@@ -743,6 +743,13 @@
+@@ -799,6 +800,13 @@
install_debug:
(cd ${debugdir} && $(MAKE) \
toolexeclibdir=$(glibcxx_toolexeclibdir)/debug install)