aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches-13.x/820-libgcc_pic.patch
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-04-27 23:03:14 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-05 15:46:37 +0200
commit29128b0bd43532404d965d22338554fce624db6a (patch)
treec176068e338aa6aa35867bc6270b9899dc912866 /toolchain/gcc/patches-13.x/820-libgcc_pic.patch
parent1e88a16248601da03d78da7939d412588ad0ea52 (diff)
downloadupstream-29128b0bd43532404d965d22338554fce624db6a.tar.gz
upstream-29128b0bd43532404d965d22338554fce624db6a.tar.bz2
upstream-29128b0bd43532404d965d22338554fce624db6a.zip
toolchain: gcc: add support for GCC 13
Release Notes: https://gcc.gnu.org/pipermail/gcc-announce/2023/000175.html Manually Refreshed: - 910-mbsd_multi.patch - 970-macos_arm64-building-fix.patch Automatically Refreshed: - 010-documentation.patch - 230-musl_libssp.patch - 300-mips_Os_cpu_rtx_cost_model.patch - 820-libgcc_pic.patch - 840-armv4_pass_fix-v4bx_to_ld.patch - 850-use_shared_libgcc.patch - 870-ppc_no_crtsavres.patch - 920-specs_nonfatal_getenv.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'toolchain/gcc/patches-13.x/820-libgcc_pic.patch')
-rw-r--r--toolchain/gcc/patches-13.x/820-libgcc_pic.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/gcc/patches-13.x/820-libgcc_pic.patch b/toolchain/gcc/patches-13.x/820-libgcc_pic.patch
index 525a95b565..7d10298190 100644
--- a/toolchain/gcc/patches-13.x/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches-13.x/820-libgcc_pic.patch
@@ -8,7 +8,7 @@ Date: Mon Oct 19 23:26:09 2009 +0000
--- a/libgcc/Makefile.in
+++ b/libgcc/Makefile.in
-@@ -930,11 +930,12 @@ $(libgcov-driver-objects): %$(objext): $
+@@ -933,11 +933,12 @@ $(libgcov-driver-objects): %$(objext): $
# Static libraries.
libgcc.a: $(libgcc-objects)
@@ -22,7 +22,7 @@ Date: Mon Oct 19 23:26:09 2009 +0000
-rm -f $@
objects="$(objects)"; \
-@@ -958,7 +959,7 @@ all: libunwind.a
+@@ -961,7 +962,7 @@ all: libunwind.a
endif
ifeq ($(enable_shared),yes)
@@ -31,7 +31,7 @@ Date: Mon Oct 19 23:26:09 2009 +0000
ifneq ($(LIBUNWIND),)
all: libunwind$(SHLIB_EXT)
libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_EXT)
-@@ -1164,6 +1165,10 @@ install-shared:
+@@ -1167,6 +1168,10 @@ install-shared:
chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
$(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a