aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-04-07 10:11:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-04-07 10:11:41 +0000
commit59f2fed12c1747c2a243a0afa865d288bd42b93b (patch)
treece932568aed6c37ea72ed891e387558e6fbfd05c /toolchain/gcc/final
parent2810bbb09a5838bfbd9ea6c9fd52f7b1a25b0964 (diff)
downloadupstream-59f2fed12c1747c2a243a0afa865d288bd42b93b.tar.gz
upstream-59f2fed12c1747c2a243a0afa865d288bd42b93b.tar.bz2
upstream-59f2fed12c1747c2a243a0afa865d288bd42b93b.zip
gcc: remove the bogus CONFIG_TLS_SUPPORT symbol - TLS support is required by libc.
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36240 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/final')
-rw-r--r--toolchain/gcc/final/Makefile8
1 files changed, 0 insertions, 8 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index e8c32f629d..2c25263db1 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -15,14 +15,6 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
--with-libelf=$(TOPDIR)/staging_dir/host
endif
-ifneq ($(CONFIG_TLS_SUPPORT),)
- GCC_CONFIGURE += \
- --enable-tls
-else
- GCC_CONFIGURE += \
- --disable-tls
-endif
-
ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
GCC_CONFIGURE += \
--enable-sjlj-exceptions