aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-09 13:35:07 +0100
committerJo-Philipp Wich <jo@mein.io>2017-12-13 14:22:36 +0100
commit3056122bf7d5a227b4c581a3b7f47680ac999952 (patch)
treed62ec3d96e4bba967bcbd47394c2cf24e40c8c70 /toolchain/gcc/final/Makefile
parenta33b0ced78035528cb8334c3f12e162f83521b03 (diff)
downloadupstream-3056122bf7d5a227b4c581a3b7f47680ac999952.tar.gz
upstream-3056122bf7d5a227b4c581a3b7f47680ac999952.tar.bz2
upstream-3056122bf7d5a227b4c581a3b7f47680ac999952.zip
toolchain/gcc: parallelize make install
If the staging dir was deleted, the build needs to recompile some files. This change speeds up this corner case significantly Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit 0f5d17a7e6acceb18867fd951b231bfb6c4d8946)
Diffstat (limited to 'toolchain/gcc/final/Makefile')
-rw-r--r--toolchain/gcc/final/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 01fec38027..b815f677d6 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -67,7 +67,7 @@ endef
define Host/Install
$(CleanupToolchain)
- $(_SINGLE)$(GCC_MAKE) -C $(GCC_BUILD_DIR) install
+ +$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) install
# Set up the symlinks to enable lying about target name.
set -e; \
(cd $(TOOLCHAIN_DIR); \