aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-05 23:21:46 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-03-17 02:08:25 +0100
commitacc8c2d829fb5e0e0b2495d720e058f91ea164b0 (patch)
treea7f615f8fa9beb8550c141c817a9bb934f40c8f2 /toolchain/gcc/common.mk
parentc44c1e1a1f18394cb855c389795ba10822e29d46 (diff)
downloadupstream-acc8c2d829fb5e0e0b2495d720e058f91ea164b0.tar.gz
upstream-acc8c2d829fb5e0e0b2495d720e058f91ea164b0.tar.bz2
upstream-acc8c2d829fb5e0e0b2495d720e058f91ea164b0.zip
toolchain/gcc: enable zstd support
LTO object files will now be compressed using zstd. Compressing debug sections with zstd will have to wait for GCC 13, which adds support for -gz=zstd. NOTE: wiping the ccache is strongly recommended, not doing so might yield build error later on: "lto1: internal compiler error: original not compressed with zstd" Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index e885141538..25f7e1ef70 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -66,6 +66,9 @@ TAR_OPTIONS += \
--exclude-from='$(CURDIR)/../exclude-testsuite' --exclude=gcc/ada/*.ad* \
--exclude=libjava
+# this needs to be without -L/-lzstd flags or other parts fail to build
+# use an absolute path to ensure it really picks up our version
+export ac_cv_search_ZSTD_compress=$(STAGING_DIR_HOST)/lib/libzstd.a -pthread
export libgcc_cv_fixed_point=no
ifdef CONFIG_INSTALL_GCCGO
export libgo_cv_c_split_stack_supported=no
@@ -103,7 +106,7 @@ GCC_CONFIGURE:= \
$(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
$(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--with-abi=elfv2)) \
--with-system-zlib=$(STAGING_DIR_HOST) \
- --without-zstd \
+ --with-zstd=$(STAGING_DIR_HOST) \
--with-gmp=$(STAGING_DIR_HOST) \
--with-mpfr=$(STAGING_DIR_HOST) \
--with-mpc=$(STAGING_DIR_HOST) \