aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorEvgeniy Didin <Evgeniy.Didin@synopsys.com>2018-01-24 20:26:03 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-27 16:46:44 +0100
commite47fe3284f25c0d7354f239ea8424b96dfe5b36d (patch)
tree3d7664b58bf65eee13543aee8fa0848036cd25c9 /toolchain/gcc/common.mk
parent53021ce7f24b0fd80a6f50517a25d762d783102b (diff)
downloadupstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.tar.gz
upstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.tar.bz2
upstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.zip
toolchain/arc: update to the most recent release arc-2017.09
This commit finally bumps ARC tools to the most recent arc-2017.09 release version. ARC GNU tools of version arc-2017.09 bring some quite significant changes like: * Binutils v2.29 with additional ARC patches * GCC 7.1.1 with additional ARC patches More information on this release could be found here: https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/tag/arc-2017.09-release Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com> CC: Alexey Brodkin <abrodkin@synopsys.com> CC: John Crispin <john@phrozen.org>
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 69214aca03..7c4e773a0f 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -41,12 +41,12 @@ ifeq ($(PKG_VERSION),7.2.0)
PKG_HASH:=1cf7adf8ff4b5aa49041c8734bbcf1ad18cc4c94d0029aae0f4e48841088479a
endif
-ifneq ($(CONFIG_GCC_VERSION_6_3_ARC),)
- PKG_VERSION:=6.3.0
+ifneq ($(CONFIG_GCC_VERSION_7_1_ARC),)
+ PKG_VERSION:=7.1.1
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/$(GCC_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(GCC_VERSION).tar.gz
- PKG_HASH:=b7223e134199b1a6f71de629da6aa845790e55d28e9892143dde09b1bc878110
- PKG_REV:=2017.03-release
+ PKG_HASH:=90596af8b9c26a434cec0a3b3d37d0c7c755ab6a65496af6ca32529fab5a6cfe
+ PKG_REV:=2017.09-release
GCC_DIR:=gcc-arc-$(PKG_REV)
HOST_BUILD_DIR = $(BUILD_DIR_HOST)/$(PKG_NAME)-$(GCC_VERSION)
endif