aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-08-18 12:13:54 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-08-18 12:13:54 +0000
commit2ce47af8ca64ba78eef4904b499681d56618ae5a (patch)
treed763b9b7608e0b44e4e3fdb935f4068b624044a5 /toolchain/gcc/common.mk
parentcc787525abaf48a2a285ca3fda77b8576a331cad (diff)
downloadupstream-2ce47af8ca64ba78eef4904b499681d56618ae5a.tar.gz
upstream-2ce47af8ca64ba78eef4904b499681d56618ae5a.tar.bz2
upstream-2ce47af8ca64ba78eef4904b499681d56618ae5a.zip
gcc: add 4.6-linaro version 4.6-2011.08
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28042 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk19
1 files changed, 14 insertions, 5 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index a24cc8bd8b..75ad8af6ff 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -36,12 +36,21 @@ ifdef CONFIG_GCC_VERSION_LLVM
PKG_SOURCE_SUBDIR:=$(GCC_DIR)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
else
-ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
- PKG_REV:=4.5-2011.08
- PKG_VERSION:=4.5.4
- PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/4.5/$(PKG_REV)/+download/
+ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
+ ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
+ PKG_REV:=4.5-2011.08
+ PKG_VERSION:=4.5.4
+ PKG_VERSION_MAJOR:=4.5
+ PKG_MD5SUM:=c3374e210209e35ad1ea175223d3605c
+ endif
+ ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
+ PKG_REV:=4.6-2011.08
+ PKG_VERSION:=4.6.2
+ PKG_VERSION_MAJOR:=4.6
+ PKG_MD5SUM:=7417cdb33d7b3a18552b2003a98cadfc
+ endif
+ PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
- PKG_MD5SUM:=c3374e210209e35ad1ea175223d3605c
GCC_DIR:=gcc-linaro-$(PKG_REV)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
else