aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-04-03 10:41:07 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-04-03 10:41:07 +0000
commit1c30e6851a9b8334b1699113b297b4e0b775581a (patch)
treef1f4f6a7906e4433f4275cd73b866acc78bcd678 /toolchain/gcc/common.mk
parent52a91b390ad7606d026ba92ccf6b407867ba1fed (diff)
downloadupstream-1c30e6851a9b8334b1699113b297b4e0b775581a.tar.gz
upstream-1c30e6851a9b8334b1699113b297b4e0b775581a.tar.bz2
upstream-1c30e6851a9b8334b1699113b297b4e0b775581a.zip
[toolchain/gcc]: remove the old (and nonworking) hack and identify our patched GCCs properly
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36189 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 154183ab1d..8305aa9fc1 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -63,6 +63,11 @@ endif
PATCH_DIR=../patches/$(GCC_VERSION)
BUGURL=https://dev.openwrt.org/
+ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
+ PKGVERSION=OpenWrt/Linaro GCC $(PKG_REV) $(REVISION)
+else
+ PKGVERSION=OpenWrt GCC $(PKG_VERSION) $(REVISION)
+endif
HOST_BUILD_PARALLEL:=1
@@ -92,6 +97,8 @@ endif
GCC_CONFIGURE:= \
SHELL="$(BASH)" \
$(HOST_SOURCE_DIR)/configure \
+ --with-bugurl=$(BUGURL) \
+ --with-pkgversion="$(PKGVERSION)" \
--prefix=$(TOOLCHAIN_DIR) \
--build=$(GNU_HOST_NAME) \
--host=$(GNU_HOST_NAME) \