aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-08-18 12:13:54 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-08-18 12:13:54 +0000
commitcca287d05e4a6253312149f71d7a7d2f2c7de898 (patch)
tree62bbe8fc7ef4df69b555968eeb21e7e0db1e0be0 /toolchain/gcc/common.mk
parentab380f46f4d24ffa2609998cc7de5ba066b92a77 (diff)
downloadupstream-cca287d05e4a6253312149f71d7a7d2f2c7de898.tar.gz
upstream-cca287d05e4a6253312149f71d7a7d2f2c7de898.tar.bz2
upstream-cca287d05e4a6253312149f71d7a7d2f2c7de898.zip
gcc: add 4.6-linaro version 4.6-2011.08
SVN-Revision: 28042
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk19
1 files changed, 14 insertions, 5 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index a24cc8bd8b..75ad8af6ff 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -36,12 +36,21 @@ ifdef CONFIG_GCC_VERSION_LLVM
PKG_SOURCE_SUBDIR:=$(GCC_DIR)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
else
-ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
- PKG_REV:=4.5-2011.08
- PKG_VERSION:=4.5.4
- PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/4.5/$(PKG_REV)/+download/
+ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
+ ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
+ PKG_REV:=4.5-2011.08
+ PKG_VERSION:=4.5.4
+ PKG_VERSION_MAJOR:=4.5
+ PKG_MD5SUM:=c3374e210209e35ad1ea175223d3605c
+ endif
+ ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
+ PKG_REV:=4.6-2011.08
+ PKG_VERSION:=4.6.2
+ PKG_VERSION_MAJOR:=4.6
+ PKG_MD5SUM:=7417cdb33d7b3a18552b2003a98cadfc
+ endif
+ PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
- PKG_MD5SUM:=c3374e210209e35ad1ea175223d3605c
GCC_DIR:=gcc-linaro-$(PKG_REV)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
else