aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-27 13:55:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-27 13:55:00 +0000
commit50be0201f13e198250ae1eed9cf89fb138cf7028 (patch)
treebd5060a305dc1dee9219657d361bf8c8a94833d2 /toolchain/gcc/common.mk
parenta844918eadee68ac3744576a61c2002131866741 (diff)
downloadupstream-50be0201f13e198250ae1eed9cf89fb138cf7028.tar.gz
upstream-50be0201f13e198250ae1eed9cf89fb138cf7028.tar.bz2
upstream-50be0201f13e198250ae1eed9cf89fb138cf7028.zip
cleanup toolchain version handling
SVN-Revision: 25148
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk8
1 files changed, 1 insertions, 7 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 4d0cafa409..977a104d00 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -48,12 +48,6 @@ else
PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
- ifeq ($(PKG_VERSION),4.1.2)
- PKG_MD5SUM:=a4a3eb15c96030906d8494959eeda23c
- endif
- ifeq ($(PKG_VERSION),4.2.4)
- PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
- endif
ifeq ($(PKG_VERSION),4.3.3)
PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
endif
@@ -126,7 +120,7 @@ ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
endif
endif
-ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
+ifeq ($(CONFIG_GCC_LLVM),)
GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \
--with-gmp=$(TOPDIR)/staging_dir/host \