aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-07-02 07:50:26 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-07-02 07:50:26 +0000
commita2c039457292e65cd2bdaa468454daac7c38ffc3 (patch)
tree5029d4837cb6501c56008e0d423bfbb3c07b3b50 /toolchain/gcc/common.mk
parent7845c7b5124c9d14483a2a9bec997b3e9a6d1620 (diff)
downloadupstream-a2c039457292e65cd2bdaa468454daac7c38ffc3.tar.gz
upstream-a2c039457292e65cd2bdaa468454daac7c38ffc3.tar.bz2
upstream-a2c039457292e65cd2bdaa468454daac7c38ffc3.zip
simplify configuration
SVN-Revision: 27353
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk15
1 files changed, 4 insertions, 11 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 2762f6ad09..d2177c5468 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -104,27 +104,20 @@ GCC_CONFIGURE:= \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
$(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
-ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
- GCC_CONFIGURE += --with-mips-plt
- endif
-endif
-
ifeq ($(CONFIG_GCC_LLVM),)
GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \
--with-gmp=$(TOPDIR)/staging_dir/host \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--disable-decimal-float
+ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+ GCC_CONFIGURE += --with-mips-plt
+ endif
endif
ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \
- --with-gmp=$(TOPDIR)/staging_dir/host \
- --with-mpc=$(TOPDIR)/staging_dir/host \
- --with-mpfr=$(TOPDIR)/staging_dir/host \
- --disable-decimal-float
+ --with-mpc=$(TOPDIR)/staging_dir/host
endif
ifneq ($(CONFIG_SSP_SUPPORT),)