aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-19 17:23:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-19 17:23:31 +0000
commit60a4353fdd5bb91d209a6fe970c70361b15a0ea5 (patch)
tree7a9124f7292dfcb53aa68c89a6831aec3f49ea22 /toolchain/gcc/Makefile
parent1f88eb26acc9cacae5467e48f53caf88fc7d2507 (diff)
downloadupstream-60a4353fdd5bb91d209a6fe970c70361b15a0ea5.tar.gz
upstream-60a4353fdd5bb91d209a6fe970c70361b15a0ea5.tar.bz2
upstream-60a4353fdd5bb91d209a6fe970c70361b15a0ea5.zip
do not use the wrapper scripts for exportable toolchains internally. on some systems the wrapper scripts are broken, and their use should be opt-in
SVN-Revision: 18454
Diffstat (limited to 'toolchain/gcc/Makefile')
-rw-r--r--toolchain/gcc/Makefile6
1 files changed, 0 insertions, 6 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 955248e81d..ea103c4539 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -246,8 +246,6 @@ define Stage2/Install
$(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
# Set up the symlinks to enable lying about target name.
set -e; \
- $(CP) ./files/wrapper.sh $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
- chmod +x $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
(cd $(TOOLCHAIN_DIR)/usr; \
ln -sf $(REAL_GNU_TARGET_NAME) $(GNU_TARGET_NAME); \
cd bin; \
@@ -255,10 +253,6 @@ define Stage2/Install
ln -sf $$$${app} \
$(GNU_TARGET_NAME)$$$${app##$(REAL_GNU_TARGET_NAME)}; \
done; \
- for app in cc gcc g++ c++ cpp ld as ; do \
- [ -f $(REAL_GNU_TARGET_NAME)-$$$${app} ] && mv $(REAL_GNU_TARGET_NAME)-$$$${app} $(REAL_GNU_TARGET_NAME)-$$$${app}.bin ; \
- ln -sf $(REAL_GNU_TARGET_NAME)-wrapper.sh $(REAL_GNU_TARGET_NAME)-$$$${app} ; \
- done; \
);
$(if $(CONFIG_EXTRA_TARGET_ARCH),$(call SetupExtraArch))
endef