aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-04 18:41:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-04 18:41:08 +0000
commit141925202ea2593083635bdb8d74dad0a165bb9d (patch)
tree1d1e54dce0fe941b55c914f484d62b7db30aca0e /toolchain/gcc/Makefile
parent010c9c48e0d3a9bf178ca036de9a97a2d62b1704 (diff)
downloadupstream-141925202ea2593083635bdb8d74dad0a165bb9d.tar.gz
upstream-141925202ea2593083635bdb8d74dad0a165bb9d.tar.bz2
upstream-141925202ea2593083635bdb8d74dad0a165bb9d.zip
fix the uclibc rebuild issue which leads to unresolved symbols in libnl (and possibly other libraries)
SVN-Revision: 15599
Diffstat (limited to 'toolchain/gcc/Makefile')
-rw-r--r--toolchain/gcc/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 346971c658..e9598d8177 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -176,6 +176,7 @@ define Stage1/Install
# XXX: glibc insists on linking against libgcc_eh
( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
[ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
+ cp libgcc.a libgcc_initial.a; \
)
endef