aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-28 07:30:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-28 07:30:25 +0000
commit018a1790a106d7c946407d6037ed1cd41ba9bcaf (patch)
treed625a9e55ef18504435df60203eefcaf505cc40d /toolchain/gcc/Makefile
parent7170cf7ed0f2bb15ea7dfc17cb9a7008793f0697 (diff)
downloadupstream-018a1790a106d7c946407d6037ed1cd41ba9bcaf.tar.gz
upstream-018a1790a106d7c946407d6037ed1cd41ba9bcaf.tar.bz2
upstream-018a1790a106d7c946407d6037ed1cd41ba9bcaf.zip
replace gcc 4.2 snapshot with 4.2.0 release (sync patches with uclibc buildroot), adjust gcc makefile for PATCH_DIR changes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7753 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/Makefile')
-rw-r--r--toolchain/gcc/Makefile7
1 files changed, 0 insertions, 7 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index d0b6658143..b5502bcefa 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -23,16 +23,10 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gcc
PKG_VERSION:=$(strip $(subst ",, $(CONFIG_GCC_VERSION)))#"))
-ifeq ($(PKG_VERSION),4.2)
-PKG_VERSION:=20060709
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PATCH_DIR=./patches/4.2
-else
PATCH_DIR=./patches/$(PKG_VERSION)
PKG_SOURCE_URL:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(PKG_VERSION) \
http://mirrors.rcn.net/pub/sourceware/gcc/releases/gcc-$(PKG_VERSION) \
ftp://ftp.gnu.org/gnu/gcc/releases/gcc-$(PKG_VERSION)
-endif
PKG_SOURCE:=gcc-$(PKG_VERSION).tar.bz2
PKG_MD5SUM:=unknown
@@ -122,7 +116,6 @@ endef
define Build/Prepare
$(call Build/Prepare/Default)
- $(SCRIPT_DIR)/patch-kernel.sh $(PKG_BUILD_DIR) $(PATCH_DIR) \*.patch
$(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(PKG_BUILD_DIR)/gcc/version.c
$(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(PKG_BUILD_DIR)/gcc/version.c
(cd $(PKG_BUILD_DIR)/libstdc++-v3; autoconf;);