aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-02-26 11:01:28 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-02-26 11:01:28 +0000
commit5f2dc3d8e9d1635a2edec99bcf21e6724cc76ac5 (patch)
tree19d009d456a92c180146e4f1acfd4bf2e3535893 /toolchain/gcc/Makefile
parent83564c9afa5ed342103954129a0419b01379cd56 (diff)
downloadupstream-5f2dc3d8e9d1635a2edec99bcf21e6724cc76ac5.tar.gz
upstream-5f2dc3d8e9d1635a2edec99bcf21e6724cc76ac5.tar.bz2
upstream-5f2dc3d8e9d1635a2edec99bcf21e6724cc76ac5.zip
[toolchain/gcc]: make TLS support configurable
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19870 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/Makefile')
-rw-r--r--toolchain/gcc/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index fe07e7d5c6..8b920607e0 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -2,7 +2,7 @@
# Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
# Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
# Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -116,6 +116,11 @@ else
--disable-libssp
endif
+ifeq ($(CONFIG_TLS_SUPPORT),)
+ GCC_CONFIGURE+= \
+ --disable-tls
+endif
+
ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
GCC_CONFIGURE+= \
--enable-biarch \
@@ -152,7 +157,6 @@ GCC_CONFIGURE_STAGE2:= \
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--enable-threads \
- --disable-tls \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
ifdef CONFIG_powerpc