aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-13 23:33:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-13 23:33:21 +0000
commit3496b2283a698efc9470c73a6f2c9647b8e85164 (patch)
tree7ebb336ad0a01ee5c5d033d62189eaedaaf9da9d /toolchain/gcc/Makefile
parent75012b27d756b6aa33f77f2f9ac617468ee3ebbf (diff)
downloadupstream-3496b2283a698efc9470c73a6f2c9647b8e85164.tar.gz
upstream-3496b2283a698efc9470c73a6f2c9647b8e85164.tar.bz2
upstream-3496b2283a698efc9470c73a6f2c9647b8e85164.zip
remove libgcc hack
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3943 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/Makefile')
-rw-r--r--toolchain/gcc/Makefile6
1 files changed, 0 insertions, 6 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index b0686297d0..e76b60b0ba 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -158,12 +158,6 @@ gcc-install: $(GCC_BUILD_DIR2)/.compiled FORCE
$(GNU_TARGET_NAME)$${app##$(REAL_GNU_TARGET_NAME)}; \
done; \
);
-# We do another ugly hack here because the standard behaviour is
-# to include a reference to libgcc.so.1 in all binaries. For flash space
-# saving, we change the specs file to link in a static libgcc here.
- if [ -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
- patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \
- fi;
source: $(DL_DIR)/$(GCC_SOURCE)
prepare: $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc