aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-01-28 15:34:33 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-01-28 15:34:33 +0000
commit0e3daa487446bae403e98bd111fbee488bfeb66b (patch)
treea97db990eccb211f2d2ce9247bab17c79b6f0311 /toolchain/gcc/Makefile
parent154efdf9f57d94462aa2d02e6c25f99dd20c8c61 (diff)
downloadupstream-0e3daa487446bae403e98bd111fbee488bfeb66b.tar.gz
upstream-0e3daa487446bae403e98bd111fbee488bfeb66b.tar.bz2
upstream-0e3daa487446bae403e98bd111fbee488bfeb66b.zip
fix libgcc handling for gcc 3.4.5 and 4.0.2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3063 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/Makefile')
-rw-r--r--toolchain/gcc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 57debe12b8..642662e8f1 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -194,8 +194,8 @@ endif
# to include a reference to libgcc.so.1 in all binaries. For flash space
# saving, we change the specs file to link in a static libgcc here.
if [ ! -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
- echo staging dir specs file is missing ; \
- /bin/false ; \
+ echo staging dir specs file is missing, assuming GCC 4.x ; \
+ $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc -dumpspecs > $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; \
fi;
if grep -q as-needed $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; then \
patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \