aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2011-06-20 11:12:46 +0000
committerMirko Vogt <mirko@openwrt.org>2011-06-20 11:12:46 +0000
commitb8fad49ff3d9a3571fe544cab23b3749e56a5c47 (patch)
treeb10e79e6daae02941241bf4e729c92c57f0e7365 /toolchain/eglibc
parentaa3bc1d684bfeaba4a1bf5675a45828139b4defc (diff)
downloadupstream-b8fad49ff3d9a3571fe544cab23b3749e56a5c47.tar.gz
upstream-b8fad49ff3d9a3571fe544cab23b3749e56a5c47.tar.bz2
upstream-b8fad49ff3d9a3571fe544cab23b3749e56a5c47.zip
Revert "[toolchain/eglibc} eglibc in fact can be built with -Os"
Compiling with -Os results in: "error: #error "glibc cannot be compiled without optimization" Still, building with -Os is listed as feature in <http://www.eglibc.org/features>: "" Building with -Os EGLIBC supports building the library with compiler optimizing for size -Os instead of for speed -O2. "" git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27245 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/eglibc')
-rw-r--r--toolchain/eglibc/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/eglibc/Makefile b/toolchain/eglibc/Makefile
index 1e1031deb8..dec7ec3c11 100644
--- a/toolchain/eglibc/Makefile
+++ b/toolchain/eglibc/Makefile
@@ -55,6 +55,10 @@ HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_installed
HOST_BUILD_DIR1:=$(HOST_BUILD_DIR)-initial
HOST_BUILD_DIR2:=$(HOST_BUILD_DIR)-final
+# XXX: {e,}glibc does not build w/ -Os
+# http://sourceware.org/bugzilla/show_bug.cgi?id=5203
+EGLIBC_CFLAGS:=$(subst -Os,-O2,$(TARGET_CFLAGS))
+
EGLIBC_CONFIGURE:= \
BUILD_CC="$(HOSTCC)" \
$(TARGET_CONFIGURE_OPTS) \