aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/headers/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-07-03 14:23:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-07-03 14:23:32 +0000
commit166ea494f126979e56daf05a48623364c992fb38 (patch)
treed759d2ce56ecb0902ac0edc363a01ef3263aaf3a /toolchain/eglibc/headers/Makefile
parentc2922b1b10d16a420bed5f380fccb9b37956504c (diff)
downloadupstream-166ea494f126979e56daf05a48623364c992fb38.tar.gz
upstream-166ea494f126979e56daf05a48623364c992fb38.tar.bz2
upstream-166ea494f126979e56daf05a48623364c992fb38.zip
toolchain: sync eglibc headers/build split with uclibc changes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32584 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/eglibc/headers/Makefile')
-rw-r--r--toolchain/eglibc/headers/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/toolchain/eglibc/headers/Makefile b/toolchain/eglibc/headers/Makefile
new file mode 100644
index 0000000000..69495c9bde
--- /dev/null
+++ b/toolchain/eglibc/headers/Makefile
@@ -0,0 +1,26 @@
+PATH_PREFIX:=..
+VARIANT:=headers
+
+include ../common.mk
+
+define Host/Compile
+
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ mkdir -p $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/{include,lib}
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ install_root="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev" \
+ install-bootstrap-headers=yes \
+ install-headers
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ csu/subdir_lib
+ ( cd $(CUR_BUILD_DIR); \
+ $(CP) csu/crt1.o csu/crti.o csu/crtn.o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/ \
+ )
+ $(TARGET_CC) -nostdlib -nostartfiles -shared -x c /dev/null \
+ -o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/libc.so
+endef
+
+$(eval $(call HostBuild))