aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-07 21:33:33 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-19 19:44:39 +0100
commit7ae4716243dda59bcff21ba0ee704322b2db10f4 (patch)
tree395e9f674feb8f4fa404b7179139d8f7f358b9ab /toolchain/binutils
parent4d384d28e44138c7619c0ab68b95cac21eeafbbf (diff)
downloadupstream-7ae4716243dda59bcff21ba0ee704322b2db10f4.tar.gz
upstream-7ae4716243dda59bcff21ba0ee704322b2db10f4.tar.bz2
upstream-7ae4716243dda59bcff21ba0ee704322b2db10f4.zip
toolchain: remove installing twice in the "initial" subdir
This was apparently introduced to recreate the toolchain (wipe staging_dir/toolchain*, but keep build_dir/toolchain*, followed by a `make toolchain/compile`). But it leaves leftovers and causes re-links to happen at src_install phase, because of the changed paths, possibly adding yet another source of issues. With the prior commits removing various hacks related to the "initial" folder we can remove installing it twice altogether. The recreated toolchain is exactly the same as before. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 636b8c4b11..42778d8d69 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -91,14 +91,9 @@ define Host/Compile
endef
define Host/Install
- mkdir -p $(TOOLCHAIN_DIR)/initial
$(MAKE) -C $(HOST_BUILD_DIR) \
- prefix=$(TOOLCHAIN_DIR)/initial \
install
- $(MAKE) -C $(HOST_BUILD_DIR) \
- prefix=$(TOOLCHAIN_DIR) \
- install
- $(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
+ $(call FixupLibdir,$(TOOLCHAIN_DIR))
$(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(HOST_BUILD_PREFIX)/bin/readelf
endef