aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorKim DoHyoung <azusahmr@k-on.kr>2022-08-11 08:13:35 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-06-25 12:32:50 +0200
commit0a63e72fbbf9dce54e9425f7f9eba1421bf777c4 (patch)
tree16b47f37fbc2af44e1cc975ee57cb90d3cba9c6e /target
parent02a37dee1b59c33e6915b6edb020c3939b809daa (diff)
downloadupstream-0a63e72fbbf9dce54e9425f7f9eba1421bf777c4.tar.gz
upstream-0a63e72fbbf9dce54e9425f7f9eba1421bf777c4.tar.bz2
upstream-0a63e72fbbf9dce54e9425f7f9eba1421bf777c4.zip
ramips: mt7621: add support for Zbtlink ZBT-WG1608 (32M)
Zbtlink ZBT-WG1608 is a Wi-Fi router intendent to use with WWAN (4G/5G) modems. Specifications: * SoC: MediaTek MT7621A * RAM: 256/512 MiB * Flash: 16/32 MiB (SPI NOR) * Wi-Fi: * MediaTek MT7603E : 2.4Ghz * MediaTek MT7613BE : 5Ghz * Ethernet: 10/100/1000 Mbps Ethernet x5 ports (4xLAN + WAN) * M.2: 1x slot with USB&SIM * EM7455/EM12-G/EM160R/RM500Q-AE * USB: 1x 3.0 Type-A port * External storage: 1x microSD (SDXC) slot * UART: console (115200 baud) * LED: * 1 power indicator * 1 WLAN 2.4G controlled (wlan 2G) * 3 SoC controlled (wlan 5G, wwan, internet) * 5 per Eth phy (4xLAN + WAN) MAC Addresses: * LAN : f8:5e:3c:xx:xx:e0 (Factory, 0xe000 (hex)) * WAN : f8:5e:3c:xx:xx:e1 (Factory, 0xe006 (hex)) * 2.4 GHz: f8:5e:3c:xx:xx:de (Factory, 0x0004 (hex)) * 5 GHz : f8:5e:3c:xx:xx:df (Factory, 0x8004 (hex)) Installation: * Vendor's firmware is OpenWrt (LEDE) based, so the sysupgrade image can be directly used to install OpenWrt. Firmware must be upgraded using the 'force' and 'do not save configuration' command line options (or correspondig web interface checkboxes) since the vendor firmware is from the pre-DSA era. Recovery Mode: * Press reset button, power up the device, wait for about 10sec. * Upload sysupgrade image through the firmware recovery mode web page at 192.168.1.1. Signed-off-by: Kim DoHyoung <azusahmr@k-on.kr> (cherry picked from commit 0bbd5699c81d6887c4d895e85b56d8c23b1211ec)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608-32m.dts16
-rw-r--r--target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608.dtsi2
-rw-r--r--target/linux/ramips/image/mt7621.mk12
3 files changed, 29 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608-32m.dts b/target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608-32m.dts
new file mode 100644
index 0000000000..00feec2ff3
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608-32m.dts
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_zbtlink_zbt-wg1608.dtsi"
+
+/ {
+ compatible = "zbtlink,zbt-wg1608-32m", "mediatek,mt7621-soc";
+ model = "Zbtlink ZBT-WG1608 (32M)";
+};
+
+&flash0 {
+ broken-flash-reset;
+};
+
+&firmware {
+ reg = <0x50000 0x1fb0000>;
+};
diff --git a/target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608.dtsi b/target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608.dtsi
index 59fab90ed1..303708fab0 100644
--- a/target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608.dtsi
+++ b/target/linux/ramips/dts/mt7621_zbtlink_zbt-wg1608.dtsi
@@ -61,7 +61,7 @@
&spi0 {
status = "okay";
- flash@0 {
+ flash0: flash@0 {
compatible = "jedec,spi-nor";
reg = <0>;
spi-max-frequency = <50000000>;
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b8fa0cefdb..a5b69839a7 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2706,6 +2706,18 @@ define Device/zbtlink_zbt-wg1608-16m
endef
TARGET_DEVICES += zbtlink_zbt-wg1608-16m
+define Device/zbtlink_zbt-wg1608-32m
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 32448k
+ DEVICE_VENDOR := Zbtlink
+ DEVICE_MODEL := ZBT-WG1608
+ DEVICE_VARIANT := 32M
+ DEVICE_PACKAGES := kmod-sdhci-mt7620 kmod-mt7603 kmod-mt7615e \
+ kmod-mt7663-firmware-ap kmod-usb3 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += zbtlink_zbt-wg1608-32m
+
define Device/zbtlink_zbt-wg2626
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)