aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-01-16 13:07:01 +0100
committerChristian Lamparter <chunkeey@gmail.com>2022-01-16 13:14:58 +0100
commit0a852d8a5e4d6eebe7f32d67b9523ef1b6b5d588 (patch)
treee18cff4ed21bac8955d56c719fdacf79f701ed52 /target
parente821849c4f9deb4d95142e15091f2423948d0d70 (diff)
downloadupstream-0a852d8a5e4d6eebe7f32d67b9523ef1b6b5d588.tar.gz
upstream-0a852d8a5e4d6eebe7f32d67b9523ef1b6b5d588.tar.bz2
upstream-0a852d8a5e4d6eebe7f32d67b9523ef1b6b5d588.zip
ipq40xx: AP-365: fix non-existent node or label "macaddr_mfginfo_1d"
Chen Minqiang reported on github: | DTC arch/arm/boot/dts/qcom-ipq4029-ap-365.dtb |qcom-ipq4019.dtsi:520.23-560.5: ERROR (phandle_references): /soc/wifi@a000000: |Reference to non-existent node or label "macaddr_mfginfo_1d" | | also defined at qcom-ipq4029-aruba-glenmorangie.dtsi:243.8-248.3 |qcom-ipq4019.dtsi:562.23-602.5: ERROR (phandle_references): /soc/wifi@a800000: |Reference to non-existent node or label "macaddr_mfginfo_1d" | | also defined at qcom-ipq4029-aruba-glenmorangie.dtsi:250.8-256.3 |ERROR: Input tree has errors, aborting (use -f to force output) |scripts/Makefile.lib:326: recipe for target 'qcom-ipq4029-ap-365.dtb' failed Fixes: cfc13c44595d ("ipq40xx: utilize nvmem-cells for macs & (pre-)calibration data") Reported-by: Chen Minqiang <ptpt52@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
index 0bc46d7e7e..d3cc73f388 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
@@ -185,6 +185,13 @@
label = "mfginfo";
reg = <0x390000 0x10000>;
read-only;
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_mfginfo_1d: macaddr@1d {
+ reg = <0x1d 0x6>;
+ };
};
partition@3a0000 {