aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2022-04-28 23:31:58 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2022-07-11 14:18:40 +0200
commitf987887e14702ef0fe63b1721f498946669e3b79 (patch)
tree9034ade8dd0fda3d1ac2c22d5070f475d5ebc166 /target
parentd545825cb36bb119d7941386c017ffa8b24c810d (diff)
downloadupstream-f987887e14702ef0fe63b1721f498946669e3b79.tar.gz
upstream-f987887e14702ef0fe63b1721f498946669e3b79.tar.bz2
upstream-f987887e14702ef0fe63b1721f498946669e3b79.zip
imx: create sdcard image recipe with raw U-Boot
Most i.MX boards booting off eMMC or SD cards use raw U-Boot located at 69 kB offset from beginning of the device - create a recipe for such image. Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx/image/common.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/imx/image/common.mk b/target/linux/imx/image/common.mk
index 8a9b260584..3b528a02b1 100644
--- a/target/linux/imx/image/common.mk
+++ b/target/linux/imx/image/common.mk
@@ -49,3 +49,13 @@ define Build/imx-sdcard
$(Build/imx-combined-image-clean)
endef
+
+define Build/imx-sdcard-raw-uboot
+ $(Build/imx-combined-image-prepare)
+
+ $(Build/imx-combined-image)
+ dd if=$(STAGING_DIR_IMAGE)/$(UBOOT)-SPL of=$@ bs=1024 seek=1 conv=notrunc
+ dd if=$(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot-dtb.img of=$@ bs=1024 seek=69 conv=notrunc
+
+ $(Build/imx-combined-image-clean)
+endef