aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSebastian Schaper <openwrt@sebastianschaper.net>2022-06-22 23:38:26 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-24 17:10:24 +0200
commitf770c33d7bb94b610d3a1c1fa84bc917678b65bc (patch)
tree709d448ba3905c2f1391491f62a7c4ce4b967cca /target
parent946e42ed89075b6c92749d7f82631331b9109edd (diff)
downloadupstream-f770c33d7bb94b610d3a1c1fa84bc917678b65bc.tar.gz
upstream-f770c33d7bb94b610d3a1c1fa84bc917678b65bc.tar.bz2
upstream-f770c33d7bb94b610d3a1c1fa84bc917678b65bc.zip
ath79: fix rootfs padding for D-Link DAP-2xxx
It was observed that `rootfs_data` was sometimes not correctly erased after performing sysupgrade, resulting in previous settings to prevail. Add call to `wrgg-pad-rootfs` in sysupgrade image recipe to ensure any previous jffs2 will be wiped, consistent with DAP-2610 from the ipq40xx target, which introduced the double-flashing procedure for these devices. Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/image/generic.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index effa3af841..24e828956c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -863,7 +863,8 @@ define Device/dlink_dap-2xxx
IMAGE/factory.img := append-kernel | pad-offset 6144k 160 | \
append-rootfs | wrgg-pad-rootfs | mkwrggimg | check-size
IMAGE/sysupgrade.bin := append-kernel | mkwrggimg | \
- pad-to $$$$(BLOCKSIZE) | append-rootfs | check-size | append-metadata
+ pad-to $$$$(BLOCKSIZE) | append-rootfs | wrgg-pad-rootfs | \
+ check-size | append-metadata
KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
KERNEL_INITRAMFS := $$(KERNEL) | mkwrggimg
endef