aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-05-25 22:07:10 +0200
committerDavid Bauer <mail@david-bauer.net>2022-06-02 16:50:12 +0200
commitb21b98627dcd6c1868d13964f6d84e8d43ae9ef7 (patch)
tree54f32bb5a27570c974024dbdf49083ef91187a30 /target
parentb641dadc1386146c4213ff6c5c443bad053a85d6 (diff)
downloadupstream-b21b98627dcd6c1868d13964f6d84e8d43ae9ef7.tar.gz
upstream-b21b98627dcd6c1868d13964f6d84e8d43ae9ef7.tar.bz2
upstream-b21b98627dcd6c1868d13964f6d84e8d43ae9ef7.zip
ipq40xx: add Aruba AP-365 specific BDF
Aruba deploys a BDF in the root filesystem, however this matches the one used for the DK04 reference board. The board-specific BDFs are built into the kernel. The AP-365 shows sinificant degraded performance with increased range when used with the reference BDF. Replace the BDF with the one extracted from Arubas kernel. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts9
-rw-r--r--target/linux/ipq40xx/image/generic.mk2
2 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
index d3cc73f388..1f7b37d56d 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4029-ap-365.dts
@@ -208,3 +208,12 @@
};
};
};
+
+&wifi0 {
+ qcom,ath10k-calibration-variant = "Aruba-AP-365";
+};
+
+&wifi1 {
+ qcom,ath10k-calibration-variant = "Aruba-AP-365";
+};
+
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index b730a0e184..44880d157c 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -185,7 +185,7 @@ TARGET_DEVICES += aruba_ap-303h
define Device/aruba_ap-365
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-365
- DEVICE_PACKAGES += kmod-hwmon-ad7418
+ DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
endef
TARGET_DEVICES += aruba_ap-365