aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-12-22 23:51:16 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-04 23:59:09 +0100
commitaa6c8c38eac8a96f3143644454806250dbe8903d (patch)
tree3833e8232a45a24aad79a64fa36fbaaf492d4d7a /target
parent0820d620123a03b6db6642acb6e950d22ffb030f (diff)
downloadupstream-aa6c8c38eac8a96f3143644454806250dbe8903d.tar.gz
upstream-aa6c8c38eac8a96f3143644454806250dbe8903d.tar.bz2
upstream-aa6c8c38eac8a96f3143644454806250dbe8903d.zip
ath79: convert Netgear WNDAP360 WiFis to nvmem-cells
Pull the calibration data from the nvmem subsystem. This allows us to move userspace caldata extraction into the device-tree definition. Merge art into partition node. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar7161_netgear_wndap360.dts55
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom6
-rw-r--r--target/linux/ath79/image/generic.mk2
3 files changed, 32 insertions, 31 deletions
diff --git a/target/linux/ath79/dts/ar7161_netgear_wndap360.dts b/target/linux/ath79/dts/ar7161_netgear_wndap360.dts
index 35c5dd36d2..21dc423c35 100644
--- a/target/linux/ath79/dts/ar7161_netgear_wndap360.dts
+++ b/target/linux/ath79/dts/ar7161_netgear_wndap360.dts
@@ -107,10 +107,34 @@
read-only;
};
- art: partition@7f0000 {
+ partition@7f0000 {
label = "art";
reg = <0x7f0000 0x010000>;
read-only;
+
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_art_0: macaddr@0 {
+ reg = <0x0 0x6>;
+ };
+
+ macaddr_art_120c: macaddr@120c {
+ reg = <0x120c 0x6>;
+ };
+
+ macaddr_art_520c: macaddr@520c {
+ reg = <0x520c 0x6>;
+ };
+
+ calibration_art_1000: calibration@1000 {
+ reg = <0x1000 0xeb8>;
+ };
+
+ calibration_art_5000: calibration@5000 {
+ reg = <0x5000 0xeb8>;
+ };
};
};
};
@@ -122,9 +146,8 @@
ath9k0: wifi@0,11 {
compatible = "pci168c,0029";
reg = <0x8800 0 0 0 0>;
- qca,no-eeprom;
- nvmem-cells = <&macaddr_art_120c>;
- nvmem-cell-names = "mac-address";
+ nvmem-cells = <&macaddr_art_120c>, <&calibration_art_1000>;
+ nvmem-cell-names = "mac-address", "calibration";
#gpio-cells = <2>;
gpio-controller;
};
@@ -132,30 +155,10 @@
ath9k1: wifi@0,12 {
compatible = "pci168c,0029";
reg = <0x9000 0 0 0 0>;
- qca,no-eeprom;
- nvmem-cells = <&macaddr_art_520c>;
- nvmem-cell-names = "mac-address";
+ nvmem-cells = <&macaddr_art_520c>, <&calibration_art_5000>;
+ nvmem-cell-names = "mac-address", "calibration";
mac-address-increment = <1>;
#gpio-cells = <2>;
gpio-controller;
};
};
-
-
-&art {
- compatible = "nvmem-cells";
- #address-cells = <1>;
- #size-cells = <1>;
-
- macaddr_art_0: macaddr@0 {
- reg = <0x0 0x6>;
- };
-
- macaddr_art_120c: macaddr@120c {
- reg = <0x120c 0x6>;
- };
-
- macaddr_art_520c: macaddr@520c {
- reg = <0x520c 0x6>;
- };
-};
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index df7f1fc0ce..961f5f46aa 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -124,8 +124,7 @@ case "$FIRMWARE" in
"ath9k-eeprom-pci-0000:00:11.0.bin")
case $board in
buffalo,wzr-600dhp|\
- buffalo,wzr-hp-ag300h|\
- netgear,wndap360)
+ buffalo,wzr-hp-ag300h)
caldata_extract "art" 0x1000 0xeb8
;;
dlink,dir-825-b1|\
@@ -144,8 +143,7 @@ case "$FIRMWARE" in
"ath9k-eeprom-pci-0000:00:12.0.bin")
case $board in
buffalo,wzr-600dhp|\
- buffalo,wzr-hp-ag300h|\
- netgear,wndap360)
+ buffalo,wzr-hp-ag300h)
caldata_extract "art" 0x5000 0xeb8
;;
dlink,dir-825-b1|\
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index d66684a124..a19412498a 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1763,7 +1763,7 @@ define Device/netgear_wndap360
$(Device/netgear_generic)
SOC := ar7161
DEVICE_MODEL := WNDAP360
- DEVICE_PACKAGES := kmod-leds-reset kmod-owl-loader
+ DEVICE_PACKAGES := kmod-leds-reset
IMAGE_SIZE := 7744k
BLOCKSIZE := 256k
KERNEL := kernel-bin | append-dtb | gzip | uImage gzip