aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2022-04-01 15:11:36 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2022-04-07 09:58:44 +0200
commita0528cab445ad6bb4b372d4484bac10f638c433f (patch)
tree5a8d23abd6cdf9bd9b44fc7c50e889e9dde17fce /target
parentbfbf235a1282485732fadc80840900d6c856e871 (diff)
downloadupstream-a0528cab445ad6bb4b372d4484bac10f638c433f.tar.gz
upstream-a0528cab445ad6bb4b372d4484bac10f638c433f.tar.bz2
upstream-a0528cab445ad6bb4b372d4484bac10f638c433f.zip
imx: image: use 'u-boot-dtb.img' filename for SPL payload
For targets in U-Boot which were migrated to DM, the correct binary image filename will be 'u-boot-dtb.img'. For backward compatibility, keep support for both files and use the one which was generated with our 'uboot-imx' package. See also 'CONFIG_SPL_FS_LOAD_PAYLOAD_NAME' and 'CONFIG_OF_CONTROL' in mainline U-Boot sources. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx/image/cortexa9.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/imx/image/cortexa9.mk b/target/linux/imx/image/cortexa9.mk
index 75e19dc694..17a507b8da 100644
--- a/target/linux/imx/image/cortexa9.mk
+++ b/target/linux/imx/image/cortexa9.mk
@@ -80,7 +80,16 @@ endef
define Build/imx6-sdcard
$(Build/imx6-combined-image-prepare)
- $(CP) $(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot.img $@.boot/u-boot.img
+ if [ -f $(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot.img ]; then \
+ $(CP) $(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot.img \
+ $@.boot/u-boot.img; \
+ fi
+
+ if [ -f $(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot-dtb.img ]; then \
+ $(CP) $(STAGING_DIR_IMAGE)/$(UBOOT)-u-boot-dtb.img \
+ $@.boot/u-boot-dtb.img; \
+ fi
+
$(Build/imx6-combined-image)
dd if=$(STAGING_DIR_IMAGE)/$(UBOOT)-SPL of=$@ bs=1024 seek=1 conv=notrunc