aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorIgnas Poklad <ignas2526@gmail.com>2022-12-18 15:14:36 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-05 00:10:14 +0100
commit7801e814dd62c98dcce3c11b3c9db86318279038 (patch)
tree72fb734493109f5a70cec03e7dbaa0ef045c27e4 /target
parentaa6c8c38eac8a96f3143644454806250dbe8903d (diff)
downloadupstream-7801e814dd62c98dcce3c11b3c9db86318279038.tar.gz
upstream-7801e814dd62c98dcce3c11b3c9db86318279038.tar.bz2
upstream-7801e814dd62c98dcce3c11b3c9db86318279038.zip
ramips: add Unielec U7621-06 32M build target
Add 32M build target Rest of the details as per commit 46ab81e405d2 ("ramips add support for UniElec U7621-06") Signed-off-by: Ignas Poklad <ignas2526@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_unielec_u7621-06-32m.dts78
-rw-r--r--target/linux/ramips/image/mt7621.mk12
2 files changed, 90 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_unielec_u7621-06-32m.dts b/target/linux/ramips/dts/mt7621_unielec_u7621-06-32m.dts
new file mode 100644
index 0000000000..dc9a9773a2
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_unielec_u7621-06-32m.dts
@@ -0,0 +1,78 @@
+// SPDX-License-Identifier: BSD-3-Clause
+/*
+ * Copyright(c) 2017 Kristian Evensen <kristian.evensen@gmail.com>.
+ * Copyright(c) 2017 Piotr Dymacz <pepe2k@gmail.com>.
+ * Copyright(c) 2018 Nishant Sharma <codemarauder@gmail.com>.
+ * All rights reserved.
+ */
+
+#include "mt7621_unielec_u7621-06.dtsi"
+
+/ {
+ compatible = "unielec,u7621-06-32m", "unielec,u7621-06", "mediatek,mt7621-soc";
+ model = "UniElec U7621-06 (32M flash)";
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <10000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "bootloader";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "config";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ firmware: partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x1fb0000>;
+ };
+ };
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_factory_e000>;
+ nvmem-cell-names = "mac-address";
+};
+
+&gmac1 {
+ nvmem-cells = <&macaddr_factory_e006>;
+ nvmem-cell-names = "mac-address";
+};
+
+&factory {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_e000: macaddr@e000 {
+ reg = <0xe000 0x6>;
+ };
+
+ macaddr_factory_e006: macaddr@e006 {
+ reg = <0xe006 0x6>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 9804b70e16..1b4e1dc039 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2147,6 +2147,18 @@ define Device/unielec_u7621-06-16m
endef
TARGET_DEVICES += unielec_u7621-06-16m
+define Device/unielec_u7621-06-32m
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 32448k
+ DEVICE_VENDOR := UniElec
+ DEVICE_MODEL := U7621-06
+ DEVICE_VARIANT := 32M
+ DEVICE_PACKAGES := kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3 -wpad-basic-wolfssl
+ SUPPORTED_DEVICES += unielec,u7621-06-32m
+endef
+TARGET_DEVICES += unielec_u7621-06-32m
+
define Device/unielec_u7621-06-64m
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)