aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-06-07 15:58:31 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-24 17:10:24 +0200
commit5fca475b1ade5dd9bf093bc4afef56badf8cf2f7 (patch)
tree2c4b4f30208c7db79519186f6f3c2f6dd6c7fb60 /target
parent9decd2a8436d2bb6b5f436268c92a6e6728486ce (diff)
downloadupstream-5fca475b1ade5dd9bf093bc4afef56badf8cf2f7.tar.gz
upstream-5fca475b1ade5dd9bf093bc4afef56badf8cf2f7.tar.bz2
upstream-5fca475b1ade5dd9bf093bc4afef56badf8cf2f7.zip
treewide: use upstream compatible for RedBoot FIS parser
No reason to keep that around, since upstream one does the same. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar7161_adtran_bsap1880.dtsi2
-rw-r--r--target/linux/bcm63xx/dts/bcm6348-inventel-livebox-1.dts2
-rw-r--r--target/linux/gemini/image/Makefile4
-rw-r--r--target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch22
-rw-r--r--target/linux/generic/pending-5.15/419-mtd-redboot-add-of_match_table-with-DT-binding.patch22
5 files changed, 4 insertions, 48 deletions
diff --git a/target/linux/ath79/dts/ar7161_adtran_bsap1880.dtsi b/target/linux/ath79/dts/ar7161_adtran_bsap1880.dtsi
index aa696f6ab5..a6ad8e490a 100644
--- a/target/linux/ath79/dts/ar7161_adtran_bsap1880.dtsi
+++ b/target/linux/ath79/dts/ar7161_adtran_bsap1880.dtsi
@@ -85,7 +85,7 @@
partitions {
#address-cells = <1>;
#size-cells = <1>;
- compatible = "ecoscentric,redboot-fis-partitions";
+ compatible = "redboot-fis";
};
};
};
diff --git a/target/linux/bcm63xx/dts/bcm6348-inventel-livebox-1.dts b/target/linux/bcm63xx/dts/bcm6348-inventel-livebox-1.dts
index df204cc51e..0b541c6081 100644
--- a/target/linux/bcm63xx/dts/bcm6348-inventel-livebox-1.dts
+++ b/target/linux/bcm63xx/dts/bcm6348-inventel-livebox-1.dts
@@ -75,7 +75,7 @@
status = "okay";
partitions {
- compatible = "ecoscentric,redboot-fis-partitions";
+ compatible = "redboot-fis";
};
};
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index c84f1926dd..3fce3172ed 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -215,8 +215,8 @@ TARGET_DEVICES += storlink_sl93512r
# The wiliboard images need some changes to be functional and buildable.
#
-# The dts would need to use the ecoscentric,redboot-fis-partitions partition
-# parser to get the correct partition offsets and size.
+# The dts would need to use the redboot-fis partition parser to get
+# the correct partition offsets and size.
#
# The mkfwimage2 call need to be adjusted to reflect the real size of kernel
# and rootfs. It is expected that the OEM firmware adjusts the on flash
diff --git a/target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch b/target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch
deleted file mode 100644
index 7692f484ae..0000000000
--- a/target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
-Subject: [PATCH] mtd: redboot: add of_match_table with DT binding
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This allows parsing RedBoot compatible partitions for properly described
-flash device in DT.
-
-Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
----
-
---- a/drivers/mtd/parsers/redboot.c
-+++ b/drivers/mtd/parsers/redboot.c
-@@ -305,6 +305,7 @@ static int parse_redboot_partitions(stru
-
- static const struct of_device_id mtd_parser_redboot_of_match_table[] = {
- { .compatible = "redboot-fis" },
-+ { .compatible = "ecoscentric,redboot-fis-partitions" },
- {},
- };
- MODULE_DEVICE_TABLE(of, mtd_parser_redboot_of_match_table);
diff --git a/target/linux/generic/pending-5.15/419-mtd-redboot-add-of_match_table-with-DT-binding.patch b/target/linux/generic/pending-5.15/419-mtd-redboot-add-of_match_table-with-DT-binding.patch
deleted file mode 100644
index 3d176f8563..0000000000
--- a/target/linux/generic/pending-5.15/419-mtd-redboot-add-of_match_table-with-DT-binding.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
-Subject: [PATCH] mtd: redboot: add of_match_table with DT binding
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This allows parsing RedBoot compatible partitions for properly described
-flash device in DT.
-
-Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
----
-
---- a/drivers/mtd/parsers/redboot.c
-+++ b/drivers/mtd/parsers/redboot.c
-@@ -304,6 +304,7 @@ nogood:
-
- static const struct of_device_id mtd_parser_redboot_of_match_table[] = {
- { .compatible = "redboot-fis" },
-+ { .compatible = "ecoscentric,redboot-fis-partitions" },
- {},
- };
- MODULE_DEVICE_TABLE(of, mtd_parser_redboot_of_match_table);