aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSemih Baskan <strstgs@gmail.com>2022-06-21 08:43:50 +0300
committerChristian Lamparter <chunkeey@gmail.com>2022-06-25 10:14:18 +0200
commit530c0a2068659944c5dbe699bd44a88695bcf8a5 (patch)
tree908344d5753080ec6cb296b9d0a7603d7b9349b6 /target
parent8c00fd9b4519bf0ef8fb3470a6df421b9f38c03c (diff)
downloadupstream-530c0a2068659944c5dbe699bd44a88695bcf8a5.tar.gz
upstream-530c0a2068659944c5dbe699bd44a88695bcf8a5.tar.bz2
upstream-530c0a2068659944c5dbe699bd44a88695bcf8a5.zip
ramips: add support for Asus RT-N12+ B1 and RT-N300 B1
Asus RT-N12+ B1 and Asus RT-N300 B1 are the same device with a different name. The OEM firmwares have the same MD5 with Asus RT-N11P B1. Same instructions for Asus RT-N11P B1 see: commit c3dc52e39ac8 ("ramips: add support for Asus RT-N10P V3 / RT-N11P B1 / RT-N12 VP B1") Signed-off-by: Semih Baskan <strstgs@gmail.com> (Added id from the PR review to commit message) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt76x8.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 81b68f6354..5bb9bf61b7 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -73,6 +73,12 @@ define Device/asus_rt-n11p-b1
DEVICE_VENDOR := Asus
DEVICE_MODEL := RT-N11P
DEVICE_VARIANT := B1
+ DEVICE_ALT0_VENDOR := ASUS
+ DEVICE_ALT0_MODEL := RT-N12+
+ DEVICE_ALT0_VARIANT := B1
+ DEVICE_ALT1_VENDOR := ASUS
+ DEVICE_ALT1_MODEL := RT-N300
+ DEVICE_ALT1_VARIANT := B1
endef
TARGET_DEVICES += asus_rt-n11p-b1