aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-08-23 19:14:47 +0200
committerDavid Bauer <mail@david-bauer.net>2022-09-06 02:57:35 +0200
commit431526be7c3a9a1ee981c99496f610c23d6ea73d (patch)
treee0ca4d3c860c0a69c90fa403315da61340685cea /target
parentae6bfb7d67c12a4e9d2c1e3f6366de5cef7b61e3 (diff)
downloadupstream-431526be7c3a9a1ee981c99496f610c23d6ea73d.tar.gz
upstream-431526be7c3a9a1ee981c99496f610c23d6ea73d.tar.bz2
upstream-431526be7c3a9a1ee981c99496f610c23d6ea73d.zip
ath79: move 5.15 testing kernel to common Makefile
All subtargets are using now 5.15 as testing kernel. Move KERNEL_TESTING_PATCHVER:=5.15 to the common Makefile. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/Makefile1
-rw-r--r--target/linux/ath79/generic/target.mk2
-rw-r--r--target/linux/ath79/mikrotik/target.mk2
-rw-r--r--target/linux/ath79/nand/target.mk2
-rw-r--r--target/linux/ath79/tiny/target.mk2
5 files changed, 1 insertions, 8 deletions
diff --git a/target/linux/ath79/Makefile b/target/linux/ath79/Makefile
index dd57d9fed9..20dae789af 100644
--- a/target/linux/ath79/Makefile
+++ b/target/linux/ath79/Makefile
@@ -9,6 +9,7 @@ SUBTARGETS:=generic mikrotik nand tiny
FEATURES:=ramdisk squashfs usbgadget
KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ath79/generic/target.mk b/target/linux/ath79/generic/target.mk
index af330b09b8..4e53c89260 100644
--- a/target/linux/ath79/generic/target.mk
+++ b/target/linux/ath79/generic/target.mk
@@ -2,8 +2,6 @@ BOARDNAME:=Generic
DEFAULT_PACKAGES += wpad-basic-wolfssl
-KERNEL_TESTING_PATCHVER:=5.15
-
define Target/Description
Build firmware images for generic Atheros AR71xx/AR913x/AR934x based boards.
endef
diff --git a/target/linux/ath79/mikrotik/target.mk b/target/linux/ath79/mikrotik/target.mk
index 697aa003c8..f5df904487 100644
--- a/target/linux/ath79/mikrotik/target.mk
+++ b/target/linux/ath79/mikrotik/target.mk
@@ -5,8 +5,6 @@ IMAGES_DIR := ../../..
DEFAULT_PACKAGES += wpad-basic-wolfssl
-KERNEL_TESTING_PATCHVER:=5.15
-
define Target/Description
Build firmware images for MikroTik devices based on Qualcomm Atheros
MIPS SoCs (AR71xx, AR72xx, AR91xx, AR93xx, QCA95xx).
diff --git a/target/linux/ath79/nand/target.mk b/target/linux/ath79/nand/target.mk
index 12694b6013..7ea9b57f45 100644
--- a/target/linux/ath79/nand/target.mk
+++ b/target/linux/ath79/nand/target.mk
@@ -4,8 +4,6 @@ FEATURES += nand
DEFAULT_PACKAGES += wpad-basic-wolfssl
-KERNEL_TESTING_PATCHVER:=5.15
-
define Target/Description
Firmware for boards using Qualcomm Atheros, MIPS-based SoCs
in the ar72xx and subsequent series, with support for NAND flash
diff --git a/target/linux/ath79/tiny/target.mk b/target/linux/ath79/tiny/target.mk
index 8241aacd3a..28e02f7a67 100644
--- a/target/linux/ath79/tiny/target.mk
+++ b/target/linux/ath79/tiny/target.mk
@@ -3,8 +3,6 @@ FEATURES += low_mem small_flash
DEFAULT_PACKAGES += wpad-basic-wolfssl
-KERNEL_TESTING_PATCHVER:=5.15
-
define Target/Description
Build firmware images for Atheros AR71xx/AR913x/AR934x based boards with small flash
endef