aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2022-12-28 12:26:21 +0100
committerSander Vanheule <sander@svanheule.net>2022-12-28 22:44:10 +0100
commit1e13081064113eb41ed62118bc49283b8c809eb8 (patch)
tree317a1f0bab4892ba35d41ae96f39862c81b9f5c1 /target
parent80be0fea03f19c8c19e8aa01380ef3d64ae353f9 (diff)
downloadupstream-1e13081064113eb41ed62118bc49283b8c809eb8.tar.gz
upstream-1e13081064113eb41ed62118bc49283b8c809eb8.tar.bz2
upstream-1e13081064113eb41ed62118bc49283b8c809eb8.zip
realtek: fix GS1900-48 firwmare partition
The listed partition size doesn't match the original partition size, and actually overlaps with the following partition. The partition node name for the "firmware" partition also has an extra 'b' compared to the partition offset. Fixes: 47f5a0a3eed5 ("realtek: Add support for ZyXEL GS1900-48 Switch") Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/dts-5.10/rtl8393_zyxel_gs1900-48.dts4
-rw-r--r--target/linux/realtek/dts-5.15/rtl8393_zyxel_gs1900-48.dts4
-rw-r--r--target/linux/realtek/image/rtl839x.mk2
3 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/realtek/dts-5.10/rtl8393_zyxel_gs1900-48.dts b/target/linux/realtek/dts-5.10/rtl8393_zyxel_gs1900-48.dts
index dd392c5a9b..48cfae6703 100644
--- a/target/linux/realtek/dts-5.10/rtl8393_zyxel_gs1900-48.dts
+++ b/target/linux/realtek/dts-5.10/rtl8393_zyxel_gs1900-48.dts
@@ -129,9 +129,9 @@
label = "jffs2";
reg = <0x160000 0x100000>;
};
- partition@b260000 {
+ partition@260000 {
label = "firmware";
- reg = <0x260000 0xda0000>;
+ reg = <0x260000 0x6d0000>;
compatible = "openwrt,uimage", "denx,uimage";
openwrt,ih-magic = <0x83800000>;
};
diff --git a/target/linux/realtek/dts-5.15/rtl8393_zyxel_gs1900-48.dts b/target/linux/realtek/dts-5.15/rtl8393_zyxel_gs1900-48.dts
index dd392c5a9b..48cfae6703 100644
--- a/target/linux/realtek/dts-5.15/rtl8393_zyxel_gs1900-48.dts
+++ b/target/linux/realtek/dts-5.15/rtl8393_zyxel_gs1900-48.dts
@@ -129,9 +129,9 @@
label = "jffs2";
reg = <0x160000 0x100000>;
};
- partition@b260000 {
+ partition@260000 {
label = "firmware";
- reg = <0x260000 0xda0000>;
+ reg = <0x260000 0x6d0000>;
compatible = "openwrt,uimage", "denx,uimage";
openwrt,ih-magic = <0x83800000>;
};
diff --git a/target/linux/realtek/image/rtl839x.mk b/target/linux/realtek/image/rtl839x.mk
index 95dae0f861..b5e669fce4 100644
--- a/target/linux/realtek/image/rtl839x.mk
+++ b/target/linux/realtek/image/rtl839x.mk
@@ -38,7 +38,7 @@ TARGET_DEVICES += tplink_sg2452p-v4
define Device/zyxel_gs1900-48
SOC := rtl8393
- IMAGE_SIZE := 13952k
+ IMAGE_SIZE := 6976k
DEVICE_VENDOR := ZyXEL
UIMAGE_MAGIC := 0x83800000
ZYXEL_VERS := AAHN