aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-11-07 00:42:57 +0100
committerDavid Bauer <mail@david-bauer.net>2022-11-08 12:16:43 +0100
commit10ba380ec3a9d0462026120ecd5f5f4fa61b5d21 (patch)
treee6e2a3b18dcb159c6348f99dcda625555ccf39f3 /target
parenta208f0a9bec723e8bec3c45cc10931494d65156b (diff)
downloadupstream-10ba380ec3a9d0462026120ecd5f5f4fa61b5d21.tar.gz
upstream-10ba380ec3a9d0462026120ecd5f5f4fa61b5d21.tar.bz2
upstream-10ba380ec3a9d0462026120ecd5f5f4fa61b5d21.zip
ramips: define loadaddr for U6 Lite DTB
The Ubiquiti UniFi 6 Lite does not correctly align the FDT by always setting fdt_high to 0xffffffff when invoking the bootubnt command. Work around this issue by loading the DTB to a valid,aligned address, so the bootloader does not have to relocate the FDT automatically. Note: The device does read the kernel before invoking bootm on the FIT image to 0x86000000. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7621.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 35817d0317..222809dbbe 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2016,6 +2016,7 @@ define Device/ubnt_unifi-6-lite
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := UniFi 6 Lite
DEVICE_DTS_CONFIG := config@1
+ DEVICE_DTS_LOADADDR := 0x87000000
DEVICE_PACKAGES += kmod-mt7603 kmod-mt7915e
KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
IMAGE_SIZE := 15424k