aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2022-09-13 16:52:50 +0200
committerSander Vanheule <sander@svanheule.net>2022-09-17 22:27:32 +0200
commitd2fa68379ff4848ab26079f7772bcf274cd3f820 (patch)
treea5ca7d37112aa2e4aa6732064e6841eb14da2d32 /target
parent51ecfb086cda76a85e150ba2bfa2267a9167cfff (diff)
downloadupstream-d2fa68379ff4848ab26079f7772bcf274cd3f820.tar.gz
upstream-d2fa68379ff4848ab26079f7772bcf274cd3f820.tar.bz2
upstream-d2fa68379ff4848ab26079f7772bcf274cd3f820.zip
realtek: move Netgear recipe to subtarget Makefile
There seems to be no reason to have the Netgear switches as part of the main Makefile. Move it to its subtarget-specific Makefile since it is only applicable there. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> [update commit message] Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/image/Makefile10
-rw-r--r--target/linux/realtek/image/rtl838x.mk10
2 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 7d35581488..6c7be4aa90 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -90,16 +90,6 @@ define Device/Default
check-size | append-metadata
endef
-# "NGE" refers to the uImage magic
-define Device/netgear_nge
- KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
- KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
- SOC := rtl8380
- IMAGE_SIZE := 14848k
- UIMAGE_MAGIC := 0x4e474520
- DEVICE_VENDOR := NETGEAR
-endef
-
include $(SUBTARGET).mk
$(eval $(call BuildImage))
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index b221ed74a2..a4f02ba352 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -105,6 +105,16 @@ define Device/iodata_bsh-g24mb
endef
TARGET_DEVICES += iodata_bsh-g24mb
+# "NGE" refers to the uImage magic
+define Device/netgear_nge
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+ SOC := rtl8380
+ IMAGE_SIZE := 14848k
+ UIMAGE_MAGIC := 0x4e474520
+ DEVICE_VENDOR := NETGEAR
+endef
+
define Device/netgear_gs108t-v3
$(Device/netgear_nge)
DEVICE_MODEL := GS108T