aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2021-08-12 22:57:39 -0700
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-08-22 22:41:41 +0200
commit96db7d2a73d5eeffc35ca5183091c131cf0aba2d (patch)
treefc2152e8f073a98828fd49a88a794169126e6193 /target
parent57807f50ded6cf0996284a850084183af13d5894 (diff)
downloadupstream-96db7d2a73d5eeffc35ca5183091c131cf0aba2d.tar.gz
upstream-96db7d2a73d5eeffc35ca5183091c131cf0aba2d.tar.bz2
upstream-96db7d2a73d5eeffc35ca5183091c131cf0aba2d.zip
ath79: rename Ubiquiti PowerBeam M (XW) to PowerBeam M5 (XW)
The commit [1] added support for Ubiquiti PowerBeam M (XW), tested on the PBE-M5-400. But, it turns out the PBE-M2-400 has a different ethernet configuration, so make the support specific to the m5 version in anticipation of adding specific support for the m2 in a separate commit. [1] 12eb5b2384a6 ("ath79: add support for Ubiquiti PowerBeam M (XW)") Signed-off-by: Russell Senior <russell@personaltelco.net> [fix model name in DTS, format commit reference in commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar9342_ubnt_powerbeam-m5-xw.dts (renamed from target/linux/ath79/dts/ar9342_ubnt_powerbeam-m-xw.dts)4
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds2
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk6
4 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/ath79/dts/ar9342_ubnt_powerbeam-m-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_powerbeam-m5-xw.dts
index 6db058f887..e5a9af3905 100644
--- a/target/linux/ath79/dts/ar9342_ubnt_powerbeam-m-xw.dts
+++ b/target/linux/ath79/dts/ar9342_ubnt_powerbeam-m5-xw.dts
@@ -3,8 +3,8 @@
#include "ar9342_ubnt_xw.dtsi"
/ {
- compatible = "ubnt,powerbeam-m-xw", "ubnt,xw", "qca,ar9342";
- model = "Ubiquiti PowerBeam M (XW)";
+ compatible = "ubnt,powerbeam-m5-xw", "ubnt,xw", "qca,ar9342";
+ model = "Ubiquiti PowerBeam M5 (XW)";
};
&mdio0 {
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 7a07b0ce6d..5707bbac4e 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -406,7 +406,7 @@ ubnt,nanostation-loco-m-xw|\
ubnt,nanostation-m|\
ubnt,nanostation-m-xw|\
ubnt,picostation-m|\
-ubnt,powerbeam-m-xw|\
+ubnt,powerbeam-m5-xw|\
ubnt,powerbridge-m|\
ubnt,rocket-m)
ucidef_set_rssimon "wlan0" "200000" "1"
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 4fe7fbc027..780068790c 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -86,7 +86,7 @@ ath79_setup_interfaces()
ubnt,picostation-m|\
ubnt,powerbeam-5ac-500|\
ubnt,powerbeam-5ac-gen2|\
- ubnt,powerbeam-m-xw|\
+ ubnt,powerbeam-m5-xw|\
ubnt,powerbridge-m|\
ubnt,rocket-5ac-lite|\
ubnt,rocket-m|\
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 01e8533fd6..547af632f6 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -328,13 +328,13 @@ define Device/ubnt_powerbeam-5ac-gen2
endef
TARGET_DEVICES += ubnt_powerbeam-5ac-gen2
-define Device/ubnt_powerbeam-m-xw
+define Device/ubnt_powerbeam-m5-xw
$(Device/ubnt-xw)
- DEVICE_MODEL := PowerBeam M
+ DEVICE_MODEL := PowerBeam M5
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += loco-m-xw
endef
-TARGET_DEVICES += ubnt_powerbeam-m-xw
+TARGET_DEVICES += ubnt_powerbeam-m5-xw
define Device/ubnt_powerbridge-m
$(Device/ubnt-xm)