aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJack Chen <redchenjs@live.com>2022-10-14 15:58:46 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-23 01:45:52 +0200
commit57577bb8ccaa79adc30e0c4b1f85a88a84e3ebfe (patch)
tree66b116b0247feadb7fc5044c2690b7e4489d6225 /target
parenta716ac55649707e8279de6f2ea66c7f6060c982c (diff)
downloadupstream-57577bb8ccaa79adc30e0c4b1f85a88a84e3ebfe.tar.gz
upstream-57577bb8ccaa79adc30e0c4b1f85a88a84e3ebfe.tar.bz2
upstream-57577bb8ccaa79adc30e0c4b1f85a88a84e3ebfe.zip
ipq40xx: convert to DSA and enable mobipromo,cm520-79f
Convert to DSA and enable the MobiPromo CM520-79F device again. Signed-off-by: Jack Chen <redchenjs@live.com> Reviewed-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/base-files/etc/board.d/01_leds6
-rw-r--r--target/linux/ipq40xx/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-cm520-79f.dts30
-rw-r--r--target/linux/ipq40xx/image/generic.mk3
4 files changed, 36 insertions, 6 deletions
diff --git a/target/linux/ipq40xx/base-files/etc/board.d/01_leds b/target/linux/ipq40xx/base-files/etc/board.d/01_leds
index 748b6f5b82..ac03c3317a 100644
--- a/target/linux/ipq40xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ipq40xx/base-files/etc/board.d/01_leds
@@ -81,9 +81,9 @@ mikrotik,sxtsq-5-ac)
ucidef_set_led_rssi "rssihigh" "rssihigh" "green:rssihigh" "wlan0" "81" "100"
;;
mobipromo,cm520-79f)
- ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth1"
- ucidef_set_led_switch "lan1" "LAN1" "blue:lan1" "switch0" "0x10"
- ucidef_set_led_switch "lan2" "LAN2" "blue:lan2" "switch0" "0x08"
+ ucidef_set_led_netdev "wan" "WAN" "blue:wan" "wan"
+ ucidef_set_led_netdev "lan1" "LAN1" "blue:lan1" "lan1"
+ ucidef_set_led_netdev "lan2" "LAN2" "blue:lan2" "lan2"
;;
netgear,ex6100v2 |\
netgear,ex6150v2)
diff --git a/target/linux/ipq40xx/base-files/etc/board.d/02_network b/target/linux/ipq40xx/base-files/etc/board.d/02_network
index 56d38bd6a7..fc9751eb13 100644
--- a/target/linux/ipq40xx/base-files/etc/board.d/02_network
+++ b/target/linux/ipq40xx/base-files/etc/board.d/02_network
@@ -56,7 +56,8 @@ ipq40xx_setup_interfaces()
compex,wpj428)
ucidef_set_interface_lan "lan1 lan2"
;;
- glinet,gl-b1300)
+ glinet,gl-b1300|\
+ mobipromo,cm520-79f)
ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
;;
mikrotik,wap-ac)
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-cm520-79f.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-cm520-79f.dts
index 036bace182..1dde17e293 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-cm520-79f.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-cm520-79f.dts
@@ -342,6 +342,36 @@
status = "okay";
};
+&gmac {
+ status = "okay";
+
+ nvmem-cells = <&macaddr_art_1006>;
+ nvmem-cell-names = "mac-address";
+};
+
+&switch {
+ status = "okay";
+};
+
+&swport3 {
+ status = "okay";
+
+ label = "lan2";
+};
+
+&swport4 {
+ status = "okay";
+
+ label = "lan1";
+};
+
+&swport5 {
+ status = "okay";
+
+ nvmem-cells = <&macaddr_art_5006>;
+ nvmem-cell-names = "mac-address";
+};
+
&wifi0 {
status = "okay";
nvmem-cell-names = "pre-calibration";
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 0a7fee159d..fd3140c2aa 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -761,8 +761,7 @@ define Device/mobipromo_cm520-79f
PAGESIZE := 2048
DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
endef
-# Missing DSA Setup
-#TARGET_DEVICES += mobipromo_cm520-79f
+TARGET_DEVICES += mobipromo_cm520-79f
define Device/netgear_ex61x0v2
$(call Device/DniImage)