aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-02 18:32:29 +0100
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-03-02 20:37:56 +0100
commit12a3c863d27d078766c84d5db170f0d7ba2d263a (patch)
tree61b9b4eeab357da9d24ebc4a1054d708b2476d51 /target
parent05603df730a5f9c24f433bf6ecf4dc1088e5fe23 (diff)
downloadupstream-12a3c863d27d078766c84d5db170f0d7ba2d263a.tar.gz
upstream-12a3c863d27d078766c84d5db170f0d7ba2d263a.tar.bz2
upstream-12a3c863d27d078766c84d5db170f0d7ba2d263a.zip
bmips: loader-lzma: drop unused RAMSIZE parameter
This parameter has never been used. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/bmips/image/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/bmips/image/Makefile b/target/linux/bmips/image/Makefile
index 86ab68d244..af2fd98d1f 100644
--- a/target/linux/bmips/image/Makefile
+++ b/target/linux/bmips/image/Makefile
@@ -5,8 +5,7 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR := 0x80010000 # RAM start + 64K
LOADER_ENTRY := 0x80a00000 # RAM start + 10M, for relocate
-RAMSIZE := 0x02000000 # 32MB
-LZMA_TEXT_START := 0x81800000 # 32MB - 8MB
+LZMA_TEXT_START := 0x81800000 # RAM start + 24M
DEVICE_VARS += CHIP_ID DEVICE_LOADADDR
@@ -32,7 +31,6 @@ define Build/loader-lzma
LOADER_NAME="$(notdir $@)" \
LZMA_TEXT_START=$(LZMA_TEXT_START) \
PKG_BUILD_DIR="$@.src" \
- RAMSIZE=$(RAMSIZE) \
TARGET_DIR="$(dir $@)" \
compile loader.$(1)
@mv "$@.$(1)" "$@"