aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-05-18 22:51:08 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-20 15:19:14 +0200
commiteab9de0c9c05e1a057e4c9112c4802c7f8fe9a3d (patch)
tree14b9a06605f5524c7714d255d426ead9371154bb /target
parent25eead21c5ab3367317051fce4ebc3552c49f86f (diff)
downloadupstream-eab9de0c9c05e1a057e4c9112c4802c7f8fe9a3d.tar.gz
upstream-eab9de0c9c05e1a057e4c9112c4802c7f8fe9a3d.tar.bz2
upstream-eab9de0c9c05e1a057e4c9112c4802c7f8fe9a3d.zip
ipq40xx: convert EZVIZ CS-W3-WD1200G-EUP to DSA
Convert the repeater to DSA. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cs-w3-wd1200g-eup.dts36
-rw-r--r--target/linux/ipq40xx/image/generic.mk3
3 files changed, 38 insertions, 2 deletions
diff --git a/target/linux/ipq40xx/base-files/etc/board.d/02_network b/target/linux/ipq40xx/base-files/etc/board.d/02_network
index cb318d36a3..28648c0db9 100644
--- a/target/linux/ipq40xx/base-files/etc/board.d/02_network
+++ b/target/linux/ipq40xx/base-files/etc/board.d/02_network
@@ -82,6 +82,7 @@ ipq40xx_setup_interfaces()
ucidef_set_interface_lan "sw-eth1 sw-eth2"
;;
aruba,ap-303h|\
+ ezviz,cs-w3-wd1200g-eup|\
netgear,rbr50|\
netgear,rbs50|\
netgear,srr60|\
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cs-w3-wd1200g-eup.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cs-w3-wd1200g-eup.dts
index dea5c2dc36..22a48c12c4 100644
--- a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cs-w3-wd1200g-eup.dts
+++ b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cs-w3-wd1200g-eup.dts
@@ -239,6 +239,42 @@
status = "okay";
};
+&gmac {
+ status = "okay";
+ nvmem-cells = <&macaddr_art_0>;
+ nvmem-cell-names = "mac-address";
+};
+
+&switch {
+ status = "okay";
+};
+
+&swport2 {
+ status = "okay";
+ label = "lan3";
+};
+
+&swport3 {
+ status = "okay";
+ label = "lan2";
+};
+
+&swport4 {
+ status = "okay";
+ label = "lan1";
+};
+
+&swport5 {
+ status = "okay";
+ label = "wan";
+ nvmem-cells = <&macaddr_art_6>;
+ nvmem-cell-names = "mac-address";
+};
+
+&ethphy0 {
+ status = "disabled";
+};
+
&wifi0 {
status = "okay";
qcom,ath10k-calibration-variant = "ezviz-cs-w3-wd1200g-eup";
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index c8b8ec936b..59bdd04296 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -555,8 +555,7 @@ define Device/ezviz_cs-w3-wd1200g-eup
DEVICE_COMPAT_MESSAGE := uboot's bootcmd has to be updated (see wiki). \
Upgrade via sysupgrade mechanism is not possible.
endef
-# Missing DSA Setup
-#TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
+TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
define Device/glinet_gl-a1300
$(call Device/FitImage)