aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2021-12-04 21:52:22 +0100
committerChristian Lamparter <chunkeey@gmail.com>2021-12-11 00:50:02 +0100
commit4deaeaa13cbcd3c4b94c69e96d7e507f201ea4cc (patch)
treeb0f3d02bc0c3687c71a055bee898dbb2e839d40b /target
parentffab23d99d980974e502989994f3aaec3f462865 (diff)
downloadupstream-4deaeaa13cbcd3c4b94c69e96d7e507f201ea4cc.tar.gz
upstream-4deaeaa13cbcd3c4b94c69e96d7e507f201ea4cc.tar.bz2
upstream-4deaeaa13cbcd3c4b94c69e96d7e507f201ea4cc.zip
x86: remove old lzma tuning patch
Chen Minqiang reported in his GitHub PR #4733 that: With CONFIG_TARGET_INITRAMFS_COMPRESSION_LZMA=y option set, the popular x86/amd64 target's initramfs-kernel failed to boot. The cause for this boot failure is that the LZMA compression uses a the first bytes to encode the compression parameters. It does not have a fixed magic. Yes, this only works if the the existing lzma options in the upstream are not changed. This patch does away with OpenWrt special LZMA options tuning since it is rather unlikely that upstream will improve the compression algorithm detection after all this time. Even though, the tuning produced a smaller initramfs (~1.1% in a spot check). Link: <https://github.com/openwrt/openwrt/pull/4733> Reported-by: Chen Minqiang <ptpt52@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/patches-5.10/011-tune_lzma_options.patch22
1 files changed, 0 insertions, 22 deletions
diff --git a/target/linux/x86/patches-5.10/011-tune_lzma_options.patch b/target/linux/x86/patches-5.10/011-tune_lzma_options.patch
deleted file mode 100644
index c19e1f54db..0000000000
--- a/target/linux/x86/patches-5.10/011-tune_lzma_options.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -370,7 +370,7 @@ quiet_cmd_bzip2 = BZIP2 $@
- # ---------------------------------------------------------------------------
-
- quiet_cmd_lzma = LZMA $@
-- cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -d20 -lc1 -lp2 -pb2 -eos -si -so; $(size_append); } > $@
-+ cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -lc8 -eos -si -so; $(size_append); } > $@
-
- quiet_cmd_lzo = LZO $@
- cmd_lzo = { cat $(real-prereqs) | $(KLZOP) -9; $(size_append); } > $@
---- a/arch/x86/include/asm/boot.h
-+++ b/arch/x86/include/asm/boot.h
-@@ -24,7 +24,7 @@
- # error "Invalid value for CONFIG_PHYSICAL_ALIGN"
- #endif
-
--#if defined(CONFIG_KERNEL_BZIP2)
-+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
- # define BOOT_HEAP_SIZE 0x400000
- #elif defined(CONFIG_KERNEL_ZSTD)
- /*