aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-05-22 22:58:58 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-05-24 19:26:41 +0100
commit34b19a852079ab41329461030839695a21fab5fb (patch)
tree9550e64a6e3d1a244a40c5ace23839be51cb3993 /target
parentd4b4926320a0a118454ccec065eac95b78215bba (diff)
downloadupstream-34b19a852079ab41329461030839695a21fab5fb.tar.gz
upstream-34b19a852079ab41329461030839695a21fab5fb.tar.bz2
upstream-34b19a852079ab41329461030839695a21fab5fb.zip
mediatek: mt7623: build SD card without all filesystems
Allow building SD card images without having both initramfs and squashfs present on the card, just like it has already been done for the mt7622 and filogic subtargets. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit d6fef27f2dd4a852ed7846e4aa5f06dcd8df91b6)
Diffstat (limited to 'target')
-rw-r--r--target/linux/mediatek/image/mt7623.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/mt7623.mk b/target/linux/mediatek/image/mt7623.mk
index 26befc1c1e..1645ecd545 100644
--- a/target/linux/mediatek/image/mt7623.mk
+++ b/target/linux/mediatek/image/mt7623.mk
@@ -104,8 +104,12 @@ define Device/bananapi_bpi-r2
pad-to 2k | append-preloader $$(UBOOT_TARGET) |\
pad-to $$(UBOOT_OFFSET) | append-bootloader $$(UBOOT_TARGET) |\
pad-to 4092k | mt7623-mbr emmc |\
+ $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),\
pad-to 4M | append-image-stage initramfs-recovery.itb |\
+ ) \
+ $(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
pad-to 48M | append-image squashfs-sysupgrade.itb |\
+ ) \
gzip
ARTIFACTS := u-boot.bin preloader.bin sdcard.img.gz
SUPPORTED_DEVICES := bananapi,bpi-r2
@@ -135,8 +139,12 @@ define Device/unielec_u7623-02
# but OpenWrt expects 'SDMM' magic for sysupgrade.
ARTIFACT/emmc.img.gz := mt7623-mbr sdmmc |\
pad-to $$(UBOOT_OFFSET) | append-bootloader $$(UBOOT_TARGET) |\
+ $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),\
pad-to 4M | append-image-stage initramfs-recovery.itb |\
+ ) \
+ $(if $(CONFIG_TARGET_ROOTFS_SQUASHFS),\
pad-to 48M | append-image squashfs-sysupgrade.itb |\
+ ) \
gzip | append-metadata
ARTIFACT/scatter.txt := scatterfile emmc.img.gz
ARTIFACTS := u-boot.bin scatter.txt emmc.img.gz